1

I just recently developed an issue trying to trigger a YONGNUO YN568EX II Flash using wireless YONGNUO YN-622C-TX triggering YN622C II receiver/triggers.

So, the mystery is everything worked yesterday. I set up everything today and fired some test shots, and the YN568II flash would not fire. I have 100% wireless control over the flash (change from ETTL to M, change flash power, zoom). ALL controls work wireless as they should. Flash pops when hitting the pilot button on the flash, flash pops when ON camera taking pics, flash pops when hitting test button on the transceiver/controller, flash pops when hitting test on the wireless receiver. Flash pops ALL times, EXCEPT when I press the shutter. Not even sure how that could be, but it's happening. It's like all the complicated stuff works, but the easy action of triggering the flash doesn't. Also, yes, batteries are good.

Also adding that I checked the wireless triggers on my Canon 430EX II flashes and they work perfectly fine (so the triggers work). Also can fire the Yongnuo using an Off-Camera Shoe Cord. Everything works except using the wireless triggers to trigger the flash.

  • 2
    Have you double-checked that the transmitter is pushed all the way into the hotshoe? Sometimes they stick a little at a point just before they're fully seated and aligned with the contacts. – junkyardsparkle Jan 18 '17 at 2:26
  • What camera model? When you say, "I have 100% wireless control over the flash..." do you mean with the menu on the YN-622C-TX or via the camera's menu? – Michael C Jan 18 '17 at 7:36
  • Okay, I double checked that the transmitter is pushed all the way into the hotshoe. No change in the outcome. Also, I have a Canon 5d MIII. What I mean by 100% wireless control over the flash is, on the YN622C-TX (mounted on the camera hotshoe), I can wirelessly change anything I want on the flash (M to ETTL, Flash Power, etc). So, wirelessly, the transceiver is certainly communicating with the flash, but it just won't trigger it to flash upon hitting the shutter on the camera. If I take the wireless trigger off of the flash, place it onto another flash, it works just fine. – PhotoGeek Jan 19 '17 at 20:16
  • I wish you had found a solution for this, as I have the same problem. The failure point is strange, because in addition to your findings, I also tried using another 622C transceiver on the camera, and that works as well. The TX will fire my canon flashes (with 622C's) but not the YN-568. – Robin Dec 28 '17 at 1:59
1

Check that the flash is correctly seated on the YN-622C, and also that the YN-622C-TX is properly seated on the camera's hotshoe, so that all pins are hitting all the contacts. It's very easy to mis-seat things, even when you think you've pushed everything forward completely.

Another possibility is that something's gotten out of whack with the 622 settings, so you may want to try doing a factory reset--this worked for me once when I couldn't suss out what might be stopping my YN-622C-TX from talking to my YN-685. From the TOYUG (The Other YN622C User Guide), the steps to reset a YN-622C II are:

  • With the power On, hold down [CH SET] and [GP SET] at the same time.

  • Keep holding until the Status indicator has winked red-green alternately 3 times and then stays red.

  • Release the buttons.

To reset the 622C-TX:

  • Hold down [MODE] plus [SYNC] at the same time. The display will show only a steady “CLR”.

  • Keep holding until “CLR” winks slowly.

  • Release the buttons.

    The Main screen will appear, showing all the groups in TTL.

Lastly, you may want to try powering on the flash and camera before you turn on the triggers.

  • Thanks inkista. Tried all of the recommendations that you made. Removed and reseated the transceiver and receiver, and cinched them down as tight as I dared. I do believe they're fully seated as the transceiver can communicate to the flash (change from M to ETTL, change flash power, etc.). Just won't pop the flash unless I hit the test button (which is further confusing). Coincidently, I now can't use highspeed sync (can change on the transceiver & flash, but can't force the camera above 1/200. Starting to think the issue is with the transceiver somehow. – PhotoGeek Jan 19 '17 at 20:24
  • Inkista, is there a similar factory reset for the YN568EX II Flash? That might be where the issue is. – PhotoGeek Jan 19 '17 at 20:34
  • @PhotoGeek there's a custom function for putting it back to factory settings, but I can't seem to find a reset procedure. You could try leaving out the batteries overnight. – inkista Jan 19 '17 at 20:45
  • I actually just found the custom reset for the flash, but that did not seem to help. I guess I'll give the batteries a try. – PhotoGeek Jan 19 '17 at 20:52
  • @PhotoGeek May also want to keep in mind that the low-low price of YN gear's gotta come from somewhere. Copy/component consistency tends to be one area. :) – inkista Jan 19 '17 at 21:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.