1

I have just purchased a Yongnuo YN622C II and the YN622C-TX. I want to set up my 580ex II off camera however, it doesn't seem to connect with the transceiver. The system works fine with my 430ex II but with the 580exII there is no response at all to triggering with the test button or trying to adjust the settings from the transmitter.

Am I doing something wrong here or is the 580ex II just not compatible with the YN622C II?

  • Is the flash set to 'slave' mode? It should not be. – Robin Sep 6 '19 at 17:43
  • The flash should not be set to slave mode. If set to slave mode, it will ignore signals from the hot foot and instead "look" for encoded optical signals from its light sensor. – Michael C Sep 7 '19 at 18:58
1

Just like your Canon 430EX II, the 580EX II is fully compatible with the YN622C system. If the flash works on the camera, it will work with the YN622C system.

Double check to make sure the flash is in normal ETTL mode, and the YN622C receiver is is set to the correct group and channel.

There could also be a connection issue with the YN622C receiver. Early 580EX IIs had rounded connection pins that were known for bad connections. Later 580EX IIs have pointy pins that make better contact. 580EX II Connection Issue

enter image description here enter image description here

| improve this answer | |
  • It's so weird. The flash definitely works on the camera and it is set to ETTL. It's as if there's some problem with the actual connection. I've tried shifting it around on the hot shoe before locking it but it doesn't seem to make any difference. – Tamara Sep 6 '19 at 16:07
  • Either it's a technical fault or I have missed something really blatantly obvious. – Tamara Sep 6 '19 at 16:08
  • Mine definitely has the round pins! I think this might be the issue. How frustrating! Thanks so much for your help - I guess I'll have to keep using the 430ex until I can get the 580 sorted! – Tamara Sep 6 '19 at 20:20
  • Along with checking channel/group settings, you should also confirm the YN622C II is set to "receive", rather than "transmit" mode. – Michael C Sep 7 '19 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.