0

I have a Canon 6D with a yongnuo yn622c-tx. My Canon Speedlite 430 II is installed on top of the yn622c receiver. This setup worked just fine for weeks, and now it doesn't. I don't know if its due to the 6D firmware update, or what.

Here's my symptoms:

  • With the above setup, the wireless controllers are triggering the flash. But my camera is not capturing it:
    • I set the 6D to Manual, with a fixed ISO. Set the flash to Manual (1/8 power). Take a shot. Flash is activated
    • Turn off the flash. Take another shot.
    • Both images have the same exposure. As if the camera didn't even see the flash.
    • I re-positioned the flash directly towards the lens. Took a shot. Camera didn't see the flash.
    • I noticed that the AF-beam on the yn622c-tx (or whatever beam in front) is not firing.

Here's my troubleshooting:

  • Canon 6D Firmware updated from 1.1.6 (I think) to 1.1.8 a month ago.
  • Canon 6D has all settings reset. There doesn't seem to be a "factory" reset, as my copyright information was preserved.
  • Yongnuo yn622c-tx Firmware was updated from 1.13 to 1.16. Reset back to factory.
  • Installed fresh AA batteries.
  • Still doesn't work. Beam on the yn622c-tx is not firing. Flash is firing, but Camera is not capturing the flash.

  • I have a Canon 5D mark I. I swapped the bodies, keeping everything else the same. The flash on the yn622c works fine. Beam on the yn622c-tx is working. Camera is capturing the flash.

  • I took off the Yongnuo Flash Controllers, installed the Speedlite on the 6D body. The Speedlite's beam works fine. The flash and camera works fine.

With my troubleshooting steps, It HAS to be the 6D body since the 5D mark I works fine. I can't figure out what's wrong, since the Speedlite's Beam works fine if it's directly on the body. It's as if the 6D firmware update told the body to stop working with the yn622c-tx.

  • It might not be only the 6D body, but the combination of body+rest. One way to be certain it is the body is to try the 6D body with the same connections with another receiver. – Fábio Dias Jul 22 at 15:13
  • Have you checked the 6D's menu to be sure that flash is enabled at all? – Michael C Jul 23 at 3:52
1

I figured out the problem.

The hotshoe on the Canon 6D was loose. It was causing the contacts on the yn622c-tx to not touch. Those contacts are a hair shorter than the Canon speedlite's contacts, which is why the 6D + speedlite was working fine.

I found a video on how to fix a loose hot shoe. https://www.youtube.com/watch?v=s_neI06o3c0

After tighten the 4 screws for the hot shoe. Everything worked.

Other symptoms: The yn622c-tx has a custom function menu, where one of the option is LEG (Legacy). This allows older camera's with 1 main hot shoe contact (instead of the 4+1) to work with the triggers. When I enabled this, the flash worked fine, although the AF-beam was not firing on the yn622c-tx.

So that got me looking into the contacts, which then lead me to notice the loose hot shoe. I also don't think I would have noticed until I compared how tight the hotshoe was on my Canon 5D mkI.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.