1

Are there any known issues with using a Yongnuo RF603N II with a Nikon D5100? I am trying to trigger a Yongnuo 560 III with the RF603N II. When I mount the 560 III directly on the D5100, it triggers from releasing the shutter.

But when I have the RF603 mounted on the D5100 releasing the shutter will not trigger the 603 through the hotshoe, but when I use the test button on the RF603 mounted on the D5100 it triggers the flash remotely. For some reason it seems like my camera is not triggering the transmitting 603 through the hotshoe. Am I missing something here?

  • What settings are you using on your Camera? Have you setup your flash in wireless receiving mode? Have you made sure that both the Flash and transmitter are on the same frequency and group? – Harry Sanderson Sep 19 '15 at 7:56
  • 2
    If the test button on the transmitter fires the flash you can eliminate any questions about the receiver on the flash - it is working. Ditto for frequency and group. The problem is clearly in the communication between the camera and transmitter. – Michael C Sep 19 '15 at 14:12
  • Thanks. Yes the communication from transmitter to flash is functioning just fine using the test button. When the YN560II is directly on the hotshoe it works fine, as do other flashes I have borrowed and tried. So I think I can eliminate the hot shoe connection on the camera itself as the culprit. – Peter Sep 20 '15 at 15:49
2

With some camera/transmitter combinations it can be way too easy to to attach the transmitter facing the wrong direction on the hot shoe. It can also be easy to not push the transmitter all the way into the hot shoe. In either case, if the connection between the transmitter and camera are not properly aligned the camera can't communicate the signal to flash to the transmitter. So be sure the pins on the bottom of the transmitter and the contacts on the camera's hot show are lining up properly.

  • Thanks. Mis-seating was certainly my thought as well. I made sure it was pushed all the way in and tightened down with the thumb screw tightener thing (technical name). I even tried to seat it fully in then back it off a little at varying amounts to see if I could get it lined up to no avail. It came as a 2 pack and neither work, which worries me. I bought from Amazon and will be swapping it out for a new set at no charge. – Peter Sep 20 '15 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.