0

This is my first time posting here and my English is also not the best so... I have a really weird problem with my Canon 600D.

First, when I take a photo (the focusing sounded normal, mirror sound was also normal, everything normal), the number of pictures I have taken is blinking all the time. Also, when I turn off the camera, there is a message: "saving picture:1" and it stays there, doesn't matter long I wait for it. I tried everything with the card and with the camera.

Second, when I push the live view button, the screen goes black and there is no more signal of life from camera (there is no reaction if you push the other buttons). To take to life the camera, should always battery out and in and the camera recover life.

Third, better take a look the picture: photo of LCD display obscured with striped pattern

It's been like this for about a week. I tried a different memory card and it still looks like this.

Hopefully somebody can help me with these issues because I'm out of warranty.

  • Two questions: first, when did this start? Second, have you tried another memory card? – mattdm Apr 24 '18 at 18:53
  • Since last week is like that...Was after use normally the camera, off and when I puted on was like.... And yeah I tried another card. Thank u for the answer – Ferdiaaza Apr 24 '18 at 18:59
  • By "To take to life the camera, should always battery out and in and the camera recover life" do you mean that taking the battery out doesn't do anything to turn the camera back on? How long are you leaving the battery out? – inkista Apr 24 '18 at 19:19
  • I mean, I need take out the battery, if i want that the camera goes on. I leave the battery no more than 1 sec out (I tried also with more time). Thank U for the answer! – Ferdiaaza Apr 24 '18 at 19:25
1

Thank u for the Answers..I solved it! I don´t know really why but...I just opened the camera, put all the cable out from the motherboard and after that, all cables in.Closed camera, Put the batery, put on, camera told me date and hour...and after that all problems were solved!! I think maybe some cable was not in the right position inside.... who knows :)

  • Awesome — glad you were fortunate in that way! – mattdm Apr 25 '18 at 16:03
0

Assuming that changing the memory card does not resolve the issue, it is super unlikely that this is something you can fix. It sounds like there is a serious problem with the electronics inside the camera.

If you're lucky, it might be a cable or something — but even then, do-it-yourself repairs are difficult.

You could send it in for repair, but as the camera model is seven years old, it's probably time to look for a replacement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.