I have a new memory card which I can't get to work with my my DSLR. My camera is a Canon 600D (aka Rebel T3i) and the memory card is a SanDisk Ultra SDHC 32 GB.

When I try to format the card (low level format checked) I get:

Err 70

Shooting is not possible due to an error.
Turn the camera off and on again or re-install the battery.

I've tried to follow the manual's instructions on Error 70 (remove and reinstall battery etc).. I've tested the camera with two other SDHC memory cards (one of which is a Transcend SDHC 32 GB class 10 - that came with the camera) and my camera reads/writes and formats without problems. I've updated the firmware to the latest version (1.0.2). I tested the SandDisk Ultra card with a canon compact camera (a Canon IXUS HS something..) which reads/writes to the card without problems. I could also format the card on my computer, but my Canon 600D still does not want to read it.

My first thought was that the card just isn't compatible with my camera, can anyone confirm if this is the case?

After some googling I found a comment from an Amazon user who seems to have tested this card with the same camera model as I have (which implies that my camera model should be compatible with this card): http://www.amazon.com/SanDisk-Ultra-Class-Memory-SDSDU-032G-AFFP/dp/B007M51J3I

(Look for the comment by the user "Wei")

So my question is: Should I suspect that there is something wrong with the camera, the memory card, or that they are just not compatible?

  • I just thought I would point out that I have never once formatted an SD or CF card for use in any device, camera or otherwise, before using it. I have SD cards that are around five years old, and CF cards that are several years old. I have never once had any problems with any of them, the CF cards remain very fast to this day, and all I ever do is write images, read them off, then delete all images on the card via the camera. So...have you tried just using the card without formatting it?
    – jrista
    Nov 18, 2013 at 23:56
  • The camera does not want to read/write to the card at all. I updated my original post, seems that the card and camera are not compatible after all.
    – Simon N
    Nov 20, 2013 at 5:27
  • @SimonN: To indicate that your question has been resolved, you can answer your own question and accept it as the best answer by clicking on the "check" symbol below the voting controls. You do not need to edit the title of your question to indicate that it is resolved. See also: Is it OK to add [Solved] to the title of a question?
    – bwDraco
    Nov 20, 2013 at 18:59
  • @DragonLord Thanks, good tip. I've reverted my edit and created a new answer.
    – Simon N
    Nov 20, 2013 at 22:03

6 Answers 6


I would check the firmware of the camera. I had a T2i with the same error and once i updated its firmware, the issue went away. My T4i doesnt have this issue as it came with SD, SDHC, and SDXC support. another good location to look is on the canon support pages for the errors you get.

for the T3i support and drivers, i would start at http://www.canon.ca/inetCA/serviceDetail?m=load&id=45&sid=7&mid=2200828&type=D&opt=1

  • Yes the firmware is up to date (1.0.2), and the camera came with an SDHC card when I bought it. The original SDHC card is, so far, still working fine.. so I was thinking maybe it's the new card's reading speed, or something similar, that is not compatible with my camera. According to the manual though, my model should support the formats SD/SDHC/SDXC.. alas not much more details on the subject.
    – Simon N
    Aug 10, 2013 at 22:51
  • since I cant add comments to answers yet, I'll put my comment down here on file systems. a camera should still have the ability to format a SD card regardless of the file format. it just wont be able to read or write the card. another option for this can be getting your computer to format the card to exFAT and going from there. I really think you should open a case with Canon. Their support is really good at getting back to people.
    – thebtm
    Aug 12, 2013 at 20:17

Make sure you have formatted the camera as FAT32. If you have formatted it as NTFS I dont think your camera will be able to read it

I think that the host device (camera) will set the speed, so I don't think that will be an issue because the camera will tell the card if it can go high speed or not.

  • Thanks then I'm ruling out the card's speed as an issue. Yes, when I'm formatting from the computer I'm formatting as FAT32. Using a Mac I select the option labeled as "MS-DOS (FAT)" in Disk Utility.
    – Simon N
    Aug 11, 2013 at 14:34
  • Frustratingly, I think you may have to send your camera back to canon. As you have a probably seen by googling the problem, there isn't much of a solution that works that you haven't already tried.
    – gcb
    Aug 12, 2013 at 9:16

Try zeroing the card out on your Mac using dd as in my answer here:

Try wiping the card by using a command like dd if=/dev/zero of=/dev/foo, where /dev/foo is the whole card (not one of its partitions; make sure you've selected the correct device!).

If you get Input/output error, the card is unusable. If this still doesn't work and you don't get this error, either the camera or the card is bad. I had a memory card that initially would not work in my old Fujifilm camera, but could successfully be formatted after running this dd command.


Try reformatting the card on a computer via a card reader (not the camera connected to the computer), just make sure the format is set to FAT32 (not FAT, not NTFS). If you get an error, call Sandisk for a card replacement.


I contacted Canon support and got the answer that the card is not compatible with the camera. They sent me this link where you can check SandDisk cards' compatibility with your device: http://pct1.sandisk.com/NewSearch.aspx

Sorry for this very late update and thanks for all the comments.


Some more leads for your question

http://www.reikan.co.uk/photography/blog/?p=1550 http://photography-on-the.net/forum/showthread.php?t=1297587

  • 3
    On Photo.SE you should always include a textual answer, not just links to potential answers. The resource you link to could disappear and leave your answer useless. It's much better to write a good answer and link to your resources. Aug 14, 2013 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.