0

Like the title says, when I attempt to use my new 128gb PNY MicroSD card, I get the message "Card cannot be accessed", where my 16gb sandisk SD still works fine. If I try to format I get the error: "Cannot format change card".

The card works fine with my computer, so at first I thought it was a problem with the formatting. I found a tool and reformatted the drive into FAT32 which my other card is using, however I still got the same error message. Am I doing something wrong?

Update: I tried partitioning the card below 32gb, and I still got the same issues.

Update 2: I borrowed another 128 msd from someone else and the camera works just fine with it. I'm going to check how this drive is formatted.

  • There is a chance the maximum GB for that camera are 64. For example on some powershoot cameras the max is 32 gb. support.usa.canon.com/kb/index?page=content&id=FAQ100296 But I can not find the max for EOS cameras. – Rafael Sep 11 '16 at 23:19
  • Would it possible to partition the drive or limit it to 64 or 32gb to get around this? – Skyler Sep 11 '16 at 23:40
  • @Rafael Please try to refrain from posting answers as comments. meta.photo.stackexchange.com/questions/4655/… – Michael C Sep 12 '16 at 0:56
  • Have you tried using the microSD card in a different microSD to SD adapter? – Michael C Sep 12 '16 at 0:56
  • @MichaelClark I only have the one, but I'm assuming it isn't the problem because my computer has no issues with it. – Skyler Sep 12 '16 at 1:12
1

I have a T3i - the two generations older camera - and it handles 128 GB without issues. That is not a proof, but a strong indication that the T5i would too.

If you google for 128 GB T5i, there are many combo offers that offer a 128 GB card together with the T5i camera.

I would assume that the speed class is insufficient, or the card or converter has an issue - or the camera has an issue.

  • It is just a T5, but I don't know if that would matter. And for clarity, the speed is 85mb/s, The card works with other devices, and the camera works with other cards – Skyler Sep 12 '16 at 1:28
  • ops missed that non existing 'i' - they are offered too, though: ebay.com/itm/… – Aganju Sep 12 '16 at 1:31
  • The OP's "update" makes this question moot; but your info appears to be correct. – Carl Witthoft Sep 12 '16 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.