1

I use a Canon Rebel T6, and it worked great for about a year and a half until the other week when I'd take a picture and look at it, it would be a half black, half purple screen. Videos work perfectly fine, and everything looks great until I take a picture. It looks the same on my computer, and I've tried to reset the camera as well. Does anyone have any idea what could cause this and if there's any way to fix it?

][

  • Did you try to make a bulb exposure? – Horitsu Jan 18 at 5:08
  • 1
    I feel like all of these "my digicam is saving busted image data" all devolve to the same "get your camera serviced if it is worth it". – jdv Jan 18 at 14:46
3

When video is properly exposed and still images are not, the most likely culprit is the shutter mechanism.

In your case, it looks like the first shutter curtain is hanging up when it is about halfway open. Thus the dark half of the frame that is still covered by the unopened shutter curtain. The malfunction apparently delays the second curtain from closing to end the exposure. Thus the other half of the frame that is grossly overexposed.

Remember, the top of the camera is the bottom of the picture due to the inversion of the image by the lens.

This is fairly easy to confirm:

  • Set the camera in Manual exposure mode
  • Remove the lens
  • Activate "Live View" to flip the mirror up
  • Set a long shutter time such as 1" (one second)
  • Press the shutter button and observe the shutter curtains

What you should see is the first curtain open from top to bottom very quickly, then the second curtain close from top to bottom.

You can also dial up a shutter time above the flash sync speed. Try 1/250 second. What you should see is the first curtain begin to open and then the second curtain beginning to close before the first curtain is all the way open. The open slit between the two curtains should travel across the sensor from top to bottom at a constant speed. It will happen fast, so don't blink or you'll miss it.

Here's a super slo-mo of shutters operating at fast speeds:

enter image description here

1

The likely answer something loose or damaged around the camera's CMOS sensor or shutter.

In my personal experience, whacking it while holding it in the correct orientation that puts the sensor back against the motherboard is useful - but it should be opened up and repaired.

Given that a lower resolution mode like video works fine, it may be electric or water damage.

  • 2
    It is almost certainly the shutter, not the sensor. Otherwise, video mode would be affected. Also, consumer camera gear hasn't used CCDs since the 80s. Everything uses CMOS sensors now. – dgatwood Jan 18 at 4:41
  • 2
    @dgatwood it is not really a point of interest if there is a CCD or a APSC or a holahopteenieweenie photon collecting sensor. The point was: its maybe broken. But I support the assessment, that the cam is broken. Sure,video works, so it could be something else than the sensor, but something is brocken. – Horitsu Jan 18 at 5:07
  • 1
    The previous comment asked why the answer was downvoted. I was just proposing the most likely reason why someone would have done so. – dgatwood Jan 18 at 7:20
  • 1
    @dgatwood There are several DSLRs and DSLTs from 2009 and 2010 which use CCD sensors, but the T6 (1300D) specifically uses CMOS. – K. Minkov Jan 18 at 14:50
  • 1
    Percussive maintenance is certainly a way to FIND intermittent faults :) BTW, more CCD cameras that are def not from the 1980s: Pentax K10D, Nikon D200 (though these two might not be pure consumer by some definitions), Sony W800, Kodak Z8612IS.... – rackandboneman Jan 19 at 13:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.