1

I've had this T3i for possibly 2 years now and it's worked fine fo this whole time, I took it out to film for the day, and the next day it was acting a little different.

Some of the main things I noticed were:

  1. I can no longer access menus, gallery or live view in these shooting presets: A_DEP,M, AV, TV, P - it only shows this screen. lcd while in these modes

  2. Along with not being able to access settings, I can only see my LCD screen in Video, all other modes (aside from modes in 1, will show the name and this screen.)screen 1, before pressing display Until I press the display button, then it shows my live screen, but also mentions that it's not available in 'this mode', except it's in every mode. screen 2 after pressing display

Here's what I've tried to fix with:

  • Resetting to factory (didn't help)

  • Setting "LCD off/on BTN" to "Remains On"(All this did was allow me to see these screens in the modes from '1', if I don't have this selected, than my LCD remains black.

  • Running the sensor cleaning (no noticeable change).

It will still take pictures and save them to gallery, but I have almost 0 control over my LCD screen in multiple modes.

Does anyone here have any idea what could of happened, or how to fix this? I am 100% positive that dirt/water/debris didn't get into the machine, it's never been dropped or banged around, any ideas?


Edits: Here is what a snapshot from a recording looks like: snapshot of recording

  • When you are in Tv, Av, or M mode what happens when you press the Info button? – Michael C Apr 19 '17 at 4:57
  • @MichaelClark the screen stays the same in all of those modes (where they show your settings). – knocked loose Apr 19 '17 at 5:02
  • Even when you press the Info button? If that is the case your camera need to be checked out by a service center (or you need to consider replacing it since fixing it could very well cost more than it is worth). – Michael C Apr 19 '17 at 5:03
  • What happens when you try to record a movie? – Michael C Apr 19 '17 at 5:04
  • 1
    I think you are missing what @MichaelClark is trying to say. The screen that your camera is stuck on is the Info screen. When that screen appears, the Info button should remove it. – Isaac Wasserman Apr 19 '17 at 20:50
1

You could try installing another firmware, like Magic Lantern, see if anything changes. If it doesn't work, you can always install the official firmware. The only caveat is that it might void your warranty.

  • I believe I tried this, but wasn't able to get to the set up menu. I would say my warranty is long past voided so I'm not worried about that. I'll try it again sometime later tonight – knocked loose Sep 18 '17 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.