1

I realize this is rather old hardware, at least as digital goes, but I'm hoping to hand it down to a friend as a starter kit. Every once in a while, my Digital Rebel XS will refuse to take a shot through the 55-250 - the switch on the lens is set to MF, the shot is clear, but all that happens is the right-most green light in the viewfinder starts blinking. Oddly, switching back to AF works - lets the shot be taken - then switching to MF it fails again. No on-screen message, just the blinking of what the user guide calls the "Focus Confirmation Light".

In the past, taking the lens off and putting it back on has cleared the problem, but not today; this time the only thing that worked was trying it on a T2i (trying to test camera vs. lens) where both AF and MF worked fine, then putting it back on the Rebel (which I hope was coincidence...)

Any ideas as to what the root cause might be? Cleaning the lens contacts didn't seem to make a difference (and as I mention above, AF mode worked fine.)

  • The camera may have a setting to prevent taking a photo when the "focus confirmation light" is blinking. If a blinking "focus confirmation light" indicates that the focus is not confirmed, this is more likely to be the case. – user50888 Apr 17 '17 at 1:53
1

Since you have tested the lens on a T2i, the problem is mostly with the older body. Get it serviced. I guess, there must be some discrepancies with the lens contacts on the XS body.

  • "Getting it serviced" will probably cost more than a Rebel XS is worth. – Michael C Apr 28 '15 at 1:54
  • From a local service guy than from Canon. – Gaurav Prabhu Apr 28 '15 at 3:49
  • 2
    It does suggest at least cleaning the contacts on the camera side, which I hadn't considered. (Is there much that servicing can even do, without a live failure to look at?) – eichin Apr 29 '15 at 2:23
0

I'm not completely convinced that there is a body hardware issue.

Even though you're focusing manually, the camera will still want to obtain a focus lock, as @BenRudgers suggests in the comments. Your manual indicates that a blinking focus confirmation light indicates a lack of obtained focus (link to manual).

If you are going to re-test, you'll want to still assign an autofocus point and make sure to manually focus on that point. Make sure you are in good light. Attempt to take a picture again. If it works, you simply had an issue obtaining focus lock while manually focusing. (I'm not sure about the Rebel, but my Pentax actually beeps and flashes the indicator point as I manually focus and nail the focus on the selected point)

Another test to run is to switch your autofocus mode to AI Servo and to test again. A key component of AI Servo is in allowing the camera to take a picture without first obtaining a focus lock. Being in manual focus mode shouldn't make a difference here. If the camera takes the shot, see above - you probably just didn't nail the focus on the selected focal point.

And while having the camera not shooting unless the focus is nailed can increase your rate of keepers, it can also mean completely losing the shot. I highly recommend, regardless of whether you use manual focus or autofocus primarily, that you look into Custom Function #9.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.