I've barely used my Speedlite 430EX II, but now I can't get it to fire with my Canon 7D while on-camera. I've tried disabling silent shooting mode, but that didn't help. I've also tried changing the flash mode (to manual and back to ETTL), the camera mode (I tried M, Av, P and full auto), and I've looked through the entire menu of the camera without finding any issue or relevant setting (the flash settings are all defaults). The device is communicating, because I do see it in the external flash function settings menu. The test button does nothing. There is no complaint about the batteries. The camera is communicating with the flash, I'm careful when mounting it, and neither is visibly dirty, so I can only assume full contact. The test button does not work when the flash is off camera either. There appears to be no slave mode setting that I can find, only ETTL and manual. I cannot find a wireless menu item related to external flash.

  • \$\begingroup\$ With the flash off camera does test work? \$\endgroup\$
    – Crazy Dino
    Commented May 10, 2017 at 12:54
  • \$\begingroup\$ Is the 430EXII in a slave mode?/Is the camera menu setting for wireless on? \$\endgroup\$
    – inkista
    Commented May 10, 2017 at 17:24

1 Answer 1


If the Test button does not work, this is a sign of internal issues, or batteries. If the Test button is not lighting up in red, then the batteries are bad, not fully charged or there is an connection issue in the battery bay. If the Test button is lighting red but pressing does nothing, then there is an internal issue with your flash, and you should contact Canon.

The Slave mode would be indicated on the LCD, as it is enabled via the Mode button.

  • \$\begingroup\$ The test button didn't light up, so I tried changing the batteries. It worked! Surprisingly bad usability - only the absence of a test light indicates the batteries are out, even when the flash display shows everything up and running. \$\endgroup\$
    – l0b0
    Commented May 10, 2017 at 18:36
  • \$\begingroup\$ To be fair l0b0, flashes have worked this way since the beginning of time, showing a 'ready' light when the capacitor is fully charged. \$\endgroup\$
    – cmason
    Commented May 10, 2017 at 19:13
  • \$\begingroup\$ A battery can't provide energy fast enough to directly power the flash. Instead, the Speedlite pulls power from the battery to charge a capacitor. When the flash fires, the capacitor can instantly supply energy to power the bulb (partially or completely draining depending on the amount of light required). But once the capacitor is low, it needs time to pull more power from the battery (recycle time) before the flash is ready again. Recycle time will increase as the batteries get low on power. \$\endgroup\$ Commented Jul 30, 2020 at 16:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.