3

I have a Lumix G7 camera, and a Hanimex TS755M external flash from a junk shop. When connected to the camera, it doesn't fire.

  • I have checked the Hanimex flash voltage, both looking it up on http://www.botzilla.com/photo/strobeVolts.html and measuring it myself --- it should be safe. (It would be nice if the G7 manual actually listed the voltage limit.)

  • The flash fires fine if I charge it and press the test button, so that bit works.

  • The camera is detecting the presence of the flash, presumably using the READY pin on the hot shoe, so that bit works.

  • If I short the central pin on the flash to the ground connector on the side, it doesn't flash. Actually, testing this again, this works fine. Apparently I just wasn't making decent contact before.

Is this pointing to a defunct flash, or is it more likely that there's a configuration issue on the camera which I'll need to fix before it'll operate the external flash (which TBH seems unlikely given that it's detected)? Alternatively, I haven't been able to find a manual for the Hanimex flash, so maybe I'm doing something wrong there; but it only has two controls...

Edit 2: here's a picture of the shoe in question. It's at an angle to show the ground connector on the side (the shoe itself is plastic and non-conductive). The extra stud on the base appears to connect to the Nikon READY pin, but who knows what that pin is doing on a Panasonic/Lumix camera.

Blunt end of flash

Edit 3: Following a suggestion in the comments below, I tried taping over the extra pin on the bottom of the shoe. This is harder than it looks as the pin is quite pointy, but it does appear that with it taped over, the camera is still detecting flash readiness and the flash still doesn't fire. So, maybe the camera is using signalling on the centre pin to detect readiness?

Edit 4: I tried the flash on another camera (an old Canon EOS). It worked absolutely fine. So there's nothing wrong with the flash.

2
  • 1
    Have you tried taping off the ready pin? (or alternatively, the non-sync contacts on the hotshoe. A piece of Scotch tape can work).
    – inkista
    Oct 2 '20 at 5:18
  • That's a good point --- I tried it. See the edit above. Oct 3 '20 at 16:42
1

By far the most likely reason for a flash not to fire is for it not to be fully pushed on.

I don't know the Hanimex TS755M: do you have an image of its flash foot? A flash that only has a single center contact (apart from the ground contact to the flash shoe) can still signal readiness to the camera by having trigger voltage on the center contact or not. While I don't think this is part of the standard, I know that my Panasonic FZ200 does likewise.

So in case that flash readiness is indeed being conveyed via the center contact on its own, the leeway for a contact problem (like incompletely mounted flash) being responsible for the flash not firing is actually rather low.

A photograph of the flash foot underside could help understanding if some communication problem may be at fault.

9
  • Good point --- I've attached a photo. I have checked that it is firmly attached to the camera, and it won't slide on any further, so I believe it's attached properly. And I tried it backwards, just to be sure. That way round it didn't register to the camera as being present, so I'm pretty sure the ready status is using that extra pin. Oct 1 '20 at 20:07
  • 1
    Ok, here I am very much out of my depth, but when buying wireless triggers for my Panasonic camera, I had to take the Canon rather than the Nikon version since the Nikon version does not work via its center contact. Now your flash has both a center contact and you were able to fire the flash via it. I suspect that your flash is misled into thinking it has a Nikon and then does not use the center contact. So I'd attempt to tape off the non-center contact (so that the flash only sees electrical action on the center contact) and see whether that makes the flash non-Nikon enough to work.
    – user95069
    Oct 1 '20 at 22:40
  • Ooh, that's a thought. I tried that, with interesting (but possibly not helpful) results. See the edit in the main text. Oct 3 '20 at 16:43
  • 1
    Ok, very stupid question: have you told your camera that it should use the flash? And you don't have anything like "burst mode" or "wireless flash mode" keeping it from doing so, and you have set "firing mode" to "Auto" (so that it will not try to do TTL or other non-existent things)?
    – user95069
    Oct 3 '20 at 17:02
  • 1
    At any rate, you'd want to set Menu/Rec/Flash/Flash mode to "Forced Flash On" (the bare lightning bolt). I've just also read the reminder "• Some commercial external flashes have synchro terminals with high-voltage or reversed polarity. Using such extra flashes may cause a malfunction or the camera may not operate normally." in the manual. Does the center pin of the flash (you said you measured it?) have a positive or negative voltage when it is ready to fire? Should be positive.
    – user95069
    Oct 3 '20 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.