This is my first external flash and I'm not sure if I'm missing anything simple. The flash works in slave mode outside of the camera. But when I mount it in the hotshoe mount I can't get it to fire. The flash is set to M (Master) mode. When I try to change the settings in the menu there is a message about the flash being incompatible or not being on. The menu item is called "External flash func. setting" and the message says "This menu cannot be displayed. Incompatible flash or flash's power is turned off."

  • I would guess you have the flash in the wrong mode. Read that manual a bit more and you should be able to fix this issue.
    – dpollitt
    Nov 1 '14 at 15:47

I was having the exact same problem but wasn't able to get it working, even after doing a ton of research. I think I have your solution if you're having the same problem that I did; the flash will not fire if you have the LCD screen active, the pulse is not emitted to the flash to trigger it unless it is being viewed through the viewfinder.

Hope that helps!

  • by the LCD screen active, you mean using Live View?
    – MikeW
    Jan 1 '15 at 8:30
  • The flash will still fire in LV as long as "silent shooting" is disabled.
    – Michael C
    Jan 10 '20 at 5:08

For camera menu control, you need to have a flash that has that feature in it. All of the flashes with that feature have all five of the pins on the foot to correspond to Canon's five hotshoe contacts so that the flash can electronically communicate with the camera (however, five pins is no guarantee of menu-command capability--e.g., even Canon's own 580EX cannot do it). A single-pin manual-only flash simply can't communicate anything other than the sync/fire signal, because it only has the one pin. That's why they're so inexpensive--they're much simpler.

However, it should fire correctly, so long as you're not attempting to do anything other than simple manual flash from the camera (i.e., it can't do TTL, HSS, 2nd curtain sync, camera menu control, OEM wireless slave mode, etc. etc. etc.) Check that the flash is correctly seated on the hotshoe, and that the batteries in it are all full charged and in good health. Make sure that the flash is out of any slave modes; putting the flash in a slave mode tells it to listen to the slave sensor, not the flash hotshoe.

See also:

  • All I want is to get the flash to fire while in the hotshoe. The flash button on the side of the camera doesn't trigger it and as you explained, the menu doesn't affect it. So how can I get it to work in manual mode while in the hotshoe? Nov 1 '14 at 5:17
  • 1
    Set the flash using the controls on the flash and then take a picture. The camera will not know that there is a flash attached, but it doesn't need to know that. The hot shoe switch should close every time the shutter is fired - whether there is a flash attached or not.
    – Michael C
    Nov 1 '14 at 15:33
  • Is the flash still in the slave mode you used for off-camera? Take it out of that. Slave mode tells the flash to ignore the hotshoe and use the sensor panel to trigger. Sorry forgot to mention that; have updated my answer.
    – inkista
    Nov 1 '14 at 15:48
  • I've tried all the modes. As I said in my question, I used M (Master) mode. That failing, I tried S1 and S2. Next I will try measuring the hot shoe switch with a multimeter to make sure it is being triggered. Nov 3 '14 at 0:46
  • Yes, you want to be in M mode. But you also have to be out of S1 or S2 mode. You can be in M and still be in S1 or S2. From the manual: "... The hotshoe’s trigger function will stop under S1 and S2 Mode."
    – inkista
    Nov 6 '14 at 23:53

The real reason has nothing to do with the LCD/LiveView, that'd be stupid, wouldn't it?

The reason is Silent Pictures.

Turn it off in the Canon menu (change to "Disable") and it will work in LiveView too.

The reason for it not working in silent mode is that the camera can't do a pre-flash as it would in normal mode, since the mirror is usually down during that. In LiveView however, the mirror is up by default when silent mode is enabled. With silent mode disabled, the mirror drops for the pre-flash (audibly) and rises up again immediately after to take the picture.

Personally, I don't know what the advantage of silent picture is and I don't need it, so disabling it was okay for me and now I can use my external flash in LiveView too.

  • 1
    thanks. for 70d, find "silent LV shoot" and disable it. the godox tt600 now works on my canon flash cable and the second one is on slave mode s1 and works also. Sep 3 '19 at 23:33

I have found a solution to the same problem but with Canon 600D + YN560 III Turn off the LCD screen and take photos through viewfinder only. The flash will not fire in live mode.

Not the answer you're looking for? Browse other questions tagged or ask your own question.