1

I have an Olympus OM-D E-M10 with the kit lens, which reads Olympus 14-42mm 1:3.5-5.6 EZ ED MSC 0.2m/0.66ft-∞, and for some reason today, when I turn it on, the lens goes in and out (zoom) automatically three times and then it stops, with the display of the camera ending totally blank. Any ideas what could be wrong?

Another lens is working just fine. I know the lens is probably dead, but I need it to work this weekend for some Christmas pictures, so, there's not much I can do right now in terms of replacing, so, anything I can try is welcome.

This is what the camera looks like when I turn it on:

enter image description here

This is what the failure looks like:

https://youtu.be/rWDs_9DdU4k

https://youtu.be/lAXxOaM2UfM

I had similar problems like this before, since I bought the camera. Every now and then, very rarelly, the lens wouldn't be detected and I would just turn it off and on again and it would work. I never had the time to explore it.

I'm not aware of the camera being dropped or bumped in any way. It was working a few days ago. I tried cleaning the contacts but that made no difference. I also tried resetting the camera.

4
  • Have you tried cleaning the contacts? Was the lens or camera recently dropped?
    – xiota
    Dec 22 '19 at 4:39
  • @xiota: I tried cleaning the contacts on both the camera and the body. They didn't look dirty, but I tried anyway. The camera wasn't dropped that I know of.
    – pupeno
    Dec 22 '19 at 11:34
  • Try the lens on a different body. If it behaves the same, it needs to be replaced. Probably not worth repair since it's a kit lens. Seems you'll probably be using your other lens during holidays.
    – xiota
    Dec 22 '19 at 19:30
  • If you're the adventurous type, you could try disassembing the lens to see if anything looks out of place.
    – xiota
    Dec 22 '19 at 19:32
1

This question is five months old, so I'm not sure if you still have this lens. I have an E-M10 III and the same lens.

Occasionally the lens doesn't extend or retract when turning on/off. Generally power-cycling (i.e. removing the battery for 30 seconds and then retrying) does work. If that doesn't work, the lens can be manually initiated:

  1. Turn off the camera
  2. Hold down the menu button and then turn the camera on.
  3. Release the menu button.
  4. Open the menu and scroll down to the wrench (called Setup Menu)
  5. Open the brightness settings, press INFO and then OK.
  6. Press UP, DOWN, LEFT, RIGHT, SHUTTER and OK. If you hit the wrong button, that doesn't matter. Simply restart this step from the beginning.
  7. You should now be on a screen labelled "Test", with two items named Prg and Item. Press the DOWN key until you reach 247 in the left box, and then press OK. The lens should then extend, zoom in, zoom out and then retract. A pause prior to retracting is normal.
  8. The camera will continue doing this until you stop it by pressing the OK button.
  9. When you are back on the program selection screen, press the left arrow to exit and then turn the switch back to off.

If the lens behaves as specified in #7, then something is likely causing issues for the lens. Have you tried removing your lens cap? While this really should not create an issue, it's worth a try.

If the lens doesn't behave, then there is definitely something wrong. If the camera body works with other lenses, I'd recommend trying to return the lens under warranty and receiving a replacement.

4
  • I still have the camera and the lens. I'll definitely try this soon.
    – pupeno
    Jun 18 '20 at 5:26
  • Awesome. Keep me updated @pupeno. The lens likely has issues but this is the easiest way to make sure.
    – wilkgr
    Jun 18 '20 at 5:32
  • Thank you, that was super interesting. On point #7, the lens behave the same as when I turn on the camera, it tried to extend a couple of times, didn't manage to extend fully, retracted and stopped. I guess the lens is dead. :(
    – pupeno
    Jul 8 '20 at 8:40
  • @pupeno That's unfortunate :(
    – wilkgr
    Jul 9 '20 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.