7

I have a Godox flash with a built-in radio trigger, and I honestly can't figure out what I'm doing wrong. I've checked that:

  • All the batteries in everything are good and everything's turned on.
  • The radio transmitter is seated fully forward into the camera hotshoe and that all the pins on the flash foot are meeting the contacts in the camera hotshoe.
  • Both the transmitter and flash use the same channel.
  • The flash is in slave mode.

But the flash isn't firing when I push the shutter button. What else should I check?

2 Answers 2

13

Here's a list of common things to check.

Are you using the wrong slave mode?

For your speedlight to be a radio slave, the antenna icon must be showing, and the backlight should be orange, and the display should show Rx for receiver, or on older models/firmware, the less-politically-correct SLAVE.

The V1, V860 III, TT685 II, and the TT685/V860II for Fuji, Olympus/Panasonic, and Pentax only have three syncing modes:

  • On-camera mode (no wireless): no icon, green backlight
  • radio master: antenna icon, green backlight
  • radio slave: antenna icon, orange backlight

But Godox's older TT685 and V860 II speedlights for Canon, Nikon, and Sony have five different syncing modes that the horizontal lightning bolt button cycles you through:

  • On-camera mode (no wireless): no icon, green backlight
  • "smart" optical master: lightning bolt icon, green backlight
  • "smart" optical slave: lightning bolt icon, orange backlight
  • radio master: antenna icon, green backlight
  • radio slave: antenna icon, orange backlight

It's easy to confuse the optical and radio modes, or to mistake the on-camera mode for radio master. Pay attention to the absence/presence of the sync mode icon on the LCD, as well as the color of the backlight.

On the TT350/V350 mini speedlights and the TT600/V850 manual single-pin speedlights, the backlight never changes color, there are no "smart" optical modes, and the antenna icon and S/M (slave/master) indicator is in the lower left corner of the LCD. Swapping modes is done with the SYNC button and dial.

Confusingly, the SLAVE button on the TT350/V350 is only good for the "dumb" S1/S2 modes when the flash is set for on-camera use in M mode.

Do the ID code settings match?

With the XPro transmitter, Godox introduced a feature called "wireless ID". This apes the PocketWizard Custom ID feature (though without PocketWizard's guaranteed unique code), where an additional digital code is used to filter out signals from other nearby trigger users on the same channel to prevent them from popping off your lights.

With newer Godox triggers, the ID is set with the MENU button and setting the ID custom function. 00 or OFF turns off the feature. 01 to 99 are the possible values for the ID code, and the code must be identically set on all units for the system to work.

All the Godox TTL-capable gear: speedlights, AD lights, X1R receiver, and transmitters can use ID codes, but may require a firmware update to have the feature. With the TT600/V850II, AC-powered monolights, or XTR16/XTR16s receivers, the ID on the transmitter must be set to 00 or OFF for the flashes to trigger.

See also: How do I tell if my Godox trigger or flash needs a firmware update?

Is your camera's flash mode set properly?

Check that you don't have flash disabled in your camera menus.

Also, at this time, AFAIK, the only camera menu system that has full two-way communication with Godox gear is Canon.

It's common for non-Canon camera menu flash settings to be grayed out or fixed to TTL when a Godox flash or transmitter is on the hotshoe. M settings will work properly so long as they're set on the transmitter. I theorize that Godox may be "faking" M power levels on non-Canon systems with TTL commands.

On non-Canon systems, despite the fact that you're using a wireless flash, you don't want to use your camera's menus for wireless flash settings, which are for their own brand's proprietary wireless systems (both optical and radio). With 3rd-party reverse-engineered gear, you typically want the camera to think the transmitter on the hotshoe is an OEM speedlight.

With Sony, it's also recommended that you set the flash mode on the camera to "Fill Flash" to get Godox gear to work properly.

Are you using the right radio trigger(s)?

The X2T cannot be used as a receiver on the foot of an off-camera flash. Godox only makes transmitter/receiver (Tx/Rx) sets. They do not make any transceiver units that can play either role. The hotshoe up top is for putting a non-Godox speedlight (or an AD200 extension head) on top of the transmitter for on-camera use.

There is a Flashpoint SPT manual-only transceiver unit that allows for sync and group control, but it's an Adorama exclusive (not a rebrand) and has no Godox-branded counterpart, so its availability outside the US is very low and (with VAT) generally costs twice what it does in the US.

The only Godox dedicated receiver unit in the system in the X1R, which only comes in Canon, Nikon, and Sony flavors. It does work with other brands of cameras, but only as a manual trigger; it does not work for cross-brand TTL/HSS like the built-in transceivers in Godox's speedlights.

The Godox FC-16 Tx/Rx triggers are not compatible with the X system, despite being 2.4 GHz.

Are you using silent/electronic shutter?

With mirrorless cameras, electronic shutter modes often disable flash. This is because the way that line-by-line readout is done lowers the sync speed to very slow values (e.g., 1/15s). To enable the flash, turn off silent or electronic shutter modes.

EFCS (electronic first/front curtain shutter) won't disable flash, but may reduce your sync speed or cause banding with HSS.

For more details on how electronic shutter affects sync speed see: dpreview's "Electronic shutter, rolling shutter and flash: what you need to know".

[Fuji only] Are you using a burst or bracketing mode?

Fuji also disables the flash hotshoe for any rapid-fire modes. Even film simulation bracketing or focus stacking disable the hotshoe.

Did you try a different channel?

Godox gear operates on the 2.4 GHz band, which is where nearly everything else wireless operates. There may be no way around an interference issue if you can't switch your location, but try changing the channel you've chosen. On the Flashpoint R2 Pro II, X2T, V1, V860 III and TT685 II, there's a SCAN function that finds and lists the least-crowded channels to use.

RF like light (and all others forms of electromagnetic radiation) follows the inverse square law. If there's a nearby wifi router, maybe moving a few feet away will fix the issue.

Are you using the flash and transmitter close together?

There is a bug in Godox's radio gear that prevents a radio connection if the transmitter and receiver units are used within one meter of each other. You have to set "close mode" on the transmitter to achieve sync.

Are you waiting long enough for the flash to recycle?

A full power burst can take seconds before the flash is ready to fire again. A TT685 is specced for full-power recycle in 2.6s with NiMh AAs, it'll be longer with alkalines. AAs can only pump so much charge so quickly to fill up the flash's capacitor. The higher your power level or the more depleted the battery, the longer it can take for the flash to recycle. Consider turning on a recycle beep to get an audible alert to signal when the flash is ready to fire again.

Are you overheating the flash?

Godox's overheat protection kicks in by a counter, not a temperature sensor. But burst-shooting, shooting at full power repeatedly, using HSS a lot, etc. particularly used in combination can be hard on any speedlight. If you're continually overheating your speedlight, consider using a larger light that can put out the same amount of light at a lower power setting.

4
  • Thanks for this. The ID code was the issue on mine. I had to set it to off as I have not patched my 350s. It was driving me nuts.
    – user85944
    Jul 23, 2019 at 4:27
  • The lightning bolt vs antenna icon tip for the TT685 fixed it for me, thanks a bunch!
    – DLH
    Mar 4, 2020 at 19:42
  • Gold! Thank you! Apr 8, 2020 at 17:50
  • @Yorkshireman You're welcome!
    – inkista
    Apr 8, 2020 at 22:58
1

Must be your wireless id. Your checked everything else inclucing the channel. The one thing everyone forgets is the id#.

1
  • The answer did not add anything to the existing and accepted one. Aug 1, 2022 at 14:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.