1
\$\begingroup\$

This is an issue that has only recently started showing up and seems to point towards something physically wrong with the camera/hotshoe somehow. The problem is any flash that I mount on camera only fires on the first shot, and doesn't on any shot after.

Turning the camera off then on again between shots is the only solution to use a flash currently, and it's obviously frustrating and not the most practical solution. Even then, the shot isn't properly exposed. I have the same exact problem with both the Godox TT685F and the Fuji EF-X8 speedlights.

The camera is in manual shutter and not electronic shutter; single shot mode and not in continuous or BKT mode. It does the same thing with the flash in both manual and TTL modes. The batteries are fully charged in both the camera and flash. I've cleaned the connector pins on the camera and flash, and the flash confirmation on the left side of screen is visible (flash icon is not crossed out) so the camera knows it has a flash mounted. A factory reset on the camera body does not affect the issue.

I haven't tried updating camera and flash firmware, in the case of the Godox. And the behavior is identical when using the Godox flash off-camera with a radio transmitter.

I was using these flashes earlier in the year no problem which is the main reason why this all confusing and seems to point towards something broken in the camera somehow. Seems like something is stopping them from firing after that first shot. Just want to see if anyone has experienced this issue before, and has possible fixes before thinking about getting camera repaired. Completely baffled what is going on. I want to avoid sending the camera in to get fixed, so knowing about any possible in-camera settings that could be causing this problem (other than the ones I've already mentioned) would be welcome.

\$\endgroup\$
3
  • 1
    \$\begingroup\$ Did anything else change about the time the flash problem started? Camera firmware update? Some seemingly unrelated camera setting? Etc.? \$\endgroup\$
    – Michael C
    Commented Nov 10, 2018 at 16:08
  • \$\begingroup\$ Nothing changed or updated since they were last working, or used, earlier in the year. Same firmware. Have tried flash again with wireless trigger, it still does the same thing and only fires on first shot and not on any shots after, doesn't expose shot properly either even when adjusting the power level on flash and camera. As far as i know I haven't touched any in-camera setting that could be affecting the flash, and have even done a factory settings reset. Turning the camera off and then on again after each shot is the only way to use a flash currently. It really does seem to be a camera pr \$\endgroup\$ Commented Nov 17, 2018 at 1:21
  • 1
    \$\begingroup\$ "I haven't tried updating camera and flash firmware" - What happens if you update all relevant firmware? \$\endgroup\$
    – xiota
    Commented Aug 14, 2019 at 21:18

2 Answers 2

1
\$\begingroup\$

The recycle time on the ex-f8 is very long–about 3 seconds I think. Make sure your flashes are charged before firing the second time

\$\endgroup\$
0
\$\begingroup\$

I have an X-T2 as well and can't figure out any way to replicate this. As a last diagnostic step, try a settings reset (in the User Setup) menu. If the problem persists, I'm afraid you'll have to either live with it or send the camera in for service.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.