It's about 6 months since I bought my Canon 70D and I still can't connect it to my smartphone. I'm feeling pretty stupid...

Yes, I've read the instructions, watched all sorts of tutorials in Youtube and this other question here.

This is what I do:

  1. Enable Wifi in Camera
  2. Create a nickname for the camera
  3. Choose the option to connect the camera using camera access point mode
  4. Go to my smartphone and I see the wifi connection with my camera nickname there
  5. Connect the phone to that wifi. After entering password, I can see it is connected
  6. Go to Camera Connect App on the smartphone and I see the message: "Camera not connected: SSID: "my nickname". Operate the camera to establish a connection". No more options are available on the smartphone.

On the camera, it says:"Start EOS application on the smartphone" (which is getting me crazy). And the only option I have on the camera is the "Cancel" button that closes the Wi-fi connection!

What the hell am I supposed to do?!


3 Answers 3


In my experience your step #6 can be a bit unpredictable. I have found that I have to go through the steps quite quickly or the WiFi on my Canon DSLR will turn off. I also have found that even after my smartphone connects to the WiFi of the DSLR, I have to click on "Images on Camera" a few times to refresh the app or something, then it finally works.

Also, make sure you are using the newest app. Canon recently moved from "EOS Remote" to "Camera Connect" although the apps are basically identical in use.

  • \$\begingroup\$ Hi, thanks, I do have "Cannon Camera Connect" \$\endgroup\$ Commented Dec 23, 2015 at 21:06
  • \$\begingroup\$ @dpollit What choice is selected for your camera before it goes into "standby" mode? Doesn't that turn off the Wi-Fi? \$\endgroup\$
    – Michael C
    Commented Dec 24, 2015 at 2:15
  • 2
    \$\begingroup\$ @dpollit I have uninstalled and installed the app again and now it is working. But only sometimes. This app seems quite unreliable... \$\endgroup\$ Commented Jan 6, 2016 at 18:56
  • \$\begingroup\$ @NunoNogueira disable you're data connection or the phone is going to try and use that network \$\endgroup\$
    – VeXii
    Commented May 23, 2017 at 16:50

you might have to disable the phones data connection(4G, 3G) before the app will use the wifi to find the camera. (annoying i know)

  • \$\begingroup\$ Never thought of that, but makes complete sense. Will try it later! Having the same issue on Canon 1300D. NFC never registers either \$\endgroup\$
    – IAmGroot
    Commented May 23, 2017 at 15:49
  • \$\begingroup\$ Tried this and can confirm it works. Even now the camera connection is remembered , I still need to disable 4G for it to be found again. Thanks. \$\endgroup\$
    – IAmGroot
    Commented May 25, 2017 at 11:58

A solution might be the same answer in How to programme EOS utility to take n number of shots.

I am unsure about EOS Utilities working for the number of shots in a row but an Android App Called DSLR Controller (Beta) works really well with my T4i and when i had a T2i. I havent tested it for the 7D mark ii yet. If you can get a micro usb to micro usb or an android tablet with a USB Port for the standard cord. the app lets you program lots of settings like number of pictures, at how many seconds apart, aperture, shutter speed, iso, change settings by brightness after each photo, etc.

I used it for a time laps of completing the patio in my backyard a few years back and it worked pretty well, to make a time laps of my buddies wedding head table, to get self photos where 10 seconds isn't enough time to get behind the camera, review my RAW images while I'm on the road some where and want to see it on a larger screen.

I would really recommend looking into it and see if it might work for your Canon Camera.

DSLR Controller (BETA) - it costs about $7.99 (CAD or USD, i forget)

Remote Release - A Test app before purchasing the DSLR Controller

The application for android claims to use WiFi as well but do not have a WiFi camera to truly test it but it doesn't hurt to try.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.