5

Just this past weekend, I got a Canon 70D, and I was so excited especially because of the wifi functionality. So I got all set up on my camera, and also got the EOS remote from Google Play store. But when I go into the app and try to connect, it doesn't even show my camera.

  • Maybe you done it but have you read this: dslrcontroller.com/guide-wifi.php – Christian Feb 3 '14 at 15:45
  • 2
    Has your phone successfully connected to the network created by your camera? – AJ Henderson Feb 3 '14 at 15:57
  • 2
    FWIW, I've also had zero luck using Infrastructrue Mode, and it's a royal pain to enter the wifi password over and over on the phone to keep trying. Access Point mode works fine for my Android tablet though. – JDługosz Sep 24 '15 at 5:44
5

The process of connecting your (in this case Android) phone to your 70D involves multiple steps. First you have to enable wifi (you do this in the menu) on the 70D (the same applies to the 6D) and this brings up the wifi function menu option. When you select the wifi function you will be prompted to register a nickname for the camera. After doing that you'll get some options like transfer images between cameras and connect to EOS utility. You want to connect to a smartphone and then you have to choose between camera access point mode and infrastructure mode. If you're shooting with an access point nearby you can connect both your phone and camera to it. If you're out in the open you can create an access point using your camera and connect your phone to it.

When you've done all this you can finally start your app and begin to remote shoot/view images.

  • Like I said in my comment, I have done everything that applies to my camera. So I know how to do that and I've done it. It's my phone that is the question. – user25814 Feb 3 '14 at 15:51
  • Are you using camera access point mode or infrastructure mode? – Hugo Feb 3 '14 at 15:52
  • Camera access point with easy connection. – user25814 Feb 3 '14 at 15:53
  • Could you first watch this video youtube.com/watch?v=LCKiJ1nOMFU to confirm that you've done everything right? – Hugo Feb 3 '14 at 15:58
  • Great! Maybe you could post an answer too. Then other people having the same problem can benefit from it too. – Hugo Feb 4 '14 at 3:07
1

If you want to use your Canon 70D with a wifi connection, enable your camera's wifi. When you get to the choice of camera access point and infrastructure mode, choose infrastructure mode. The 70D's network list will then pop up with all of the wifi hotspots near you. Click on your wifi connection and then type in the password. Once that is done, you should be set for your camera.

Now go to your phone, make sure that you are connected to the same wifi, of course, and then launch the EOS remote app, and click on the bottom button that says camera connection and it should detect your camera. Click that and have fun!

  • This is what usually gets me when I turn on the camera and try to connect to it with my phone. Access point is handy when you're in the field and are not already connected to wifi with your phone. Your phone and camera need to be on the same network, so if your phone is already connected to an access point then you need to connect your camera to that same access point or connect your phone to the access point provided by the camera. – tenmiles Feb 4 '14 at 23:00
  • So you don't need to turn on wifi on your phone when your in access point? – user25814 Feb 5 '14 at 14:42
  • 2
    There needs to be a common network to connect the phone to the camera and there are two options for this: 1) a normal router/wifi access point that both camera and phone connect to, or 2) the camera is the access point and the phone connects to it. I often forget that my phone is connected to a different access point when I have my camera configured to be the access point. – tenmiles Feb 5 '14 at 14:43
1

You have to set it up on the camera first. Go to the WiFi menu on your camera, assign the WiFi network a name, and add encryption number. Once the camera is set up, it will broadcast its WiFi. Then, open the App. It will find the camera, ask if you'd like to add that camera, then voila! WiFi control. It works quite well too with the new app. I used it as a remote control.

1

I have been trying to get it to work since November when the pixel phone first came out. The technical support team at Canon is very nice and helpful but do not know the answer. Turn off Bluetooth on the phone if you have Wi-Fi on. Having Wi-Fi and Bluetooth on will not allow the pixel phone to see the app. Then you can load the Canon Connect app and it should work properly

0

While writing this post i connected canon camera connect app with my Smartphone. Key is to First Enable the WIFI and then open a WIFI function.

Authenticate Manually.

Even after 2 Yrs after this Post, Users are still facing issues with Automatic authentication.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.