0
\$\begingroup\$

After buying a new camera I realized that Lightroom 5.7.1 (Adobe stopped to sell permanent licenses, so I did not (and won't) upgrade) would not recognize the newer RAW format (Panasonic Raw Version: 0390). So I downloaded the latest DNG converter (version 14.1) to convert the RAW files to DNG. The DNG written is DNG Version 1.4, still containing the CFA (not linearized AFAIK), but Lightroom 5.7.1 seems to handle it (i.e.: it's selectable for import).

Unfortunately I'm confused with the settings of the DNG Converter: The converter talks about Camera RAW versions, not about DNG or Lightroom versions. What adds to the confusion is that the major versions of Camera RAW seem to be 2, 4, 5, 6, 7, 11, 12, and 13. So I wonder about versions 8, 9, and 10.

In addition Adobe Digital Negative Converter talks about Lightroom version 4.1 matching Camera Raw 7.1, but the next is Lightroom version 11.2 matching Camera RAW 11.2. Does Adobe deny the existence of Lightroom versions 5.x (and 6)?

Which DNG or Camera RAW version will best fit Lightroom 5.7.1?

\$\endgroup\$
2
  • \$\begingroup\$ This appears to require nothing more than the ability to parse the phrase "and later". \$\endgroup\$
    – Tetsujin
    Jan 16, 2022 at 19:14
  • \$\begingroup\$ You are referring to "Camera Raw 7.1 and later: The DNG file will be readable by Camera Raw 7.1 (Photoshop CS6) and later, and Lightroom 4.1 and later."? If so, is it saying that any Camera Raw version starting at 7.1 can be used starting with Lightroom 4.1? For me there is on "and later" too much in the sentence. \$\endgroup\$
    – U. Windl
    Jan 16, 2022 at 19:18

1 Answer 1

1
\$\begingroup\$

Camera Raw 7.1 and later: The DNG file will be readable by Camera Raw 7.1 (Photoshop CS6) and later, and Lightroom 4.1 and later. The DNG file will often be readable by earlier versions, depending on the camera model.

Camera Raw 11.2 and later: The DNG file will be readable by Camera Raw 11.2(Photoshop 20) and later, and Lightroom 8.2 and later.

From these two follows directly that any LR version >= 4.1 and < 8.2 will need the CR 7.1 compatibility setting.

\$\endgroup\$
3
  • \$\begingroup\$ I'm still wondering about the "gap" described in the question. Despite of that helpx.adobe.com/camera-raw/kb/… says that my camera needs at least Lightroom 6.14 and Camera Raw 10.1. To make the confusion complete the same line also says "Minimum Lightroom version required" is 1.1. I'm as clever as before. \$\endgroup\$
    – U. Windl
    Jan 16, 2022 at 19:52
  • 2
    \$\begingroup\$ your camera needs that version if you want to read the raw files directly. \$\endgroup\$
    – ths
    Jan 16, 2022 at 20:43
  • \$\begingroup\$ there is no gap. if you set the compatibility to 7.1 and later, all products which are based on this CR version (which include LR4.1) or any higher version will be able to read the file. it's really simple. \$\endgroup\$
    – ths
    Jan 16, 2022 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.