2

I have been lately shooting some photos with my old Canon 450D (or Rebel XSi) in RAW+JPEG mode and then trying to edit the photos in Lightroom 6.0. I've tried importing the photos to Lightroom both from the Photos app (on macOS Sierra, by exporting the unmodified originals) and straight from the camera, but will always only get an error message saying

The files are not recognized by the raw format support in Lightroom. (90)

I then tried taking a photo in RAW-only mode and importing it straight from the camera, and that seemed to work fine.

So, are the RAW files saved in RAW+JPEG mode somehow different from the files the RAW-only mode generates? Or why is Lightroom able to read one of them but not the other?

I've also tried deleting the accompanying JPEG photos from the directory that I'm importing the RAW photos from and setting the option "Treat JPEG files next to raw files as separate photos" in Lightroom preferences but still get the same error.

Edit: It seems the free Adobe DNG Converter has the same problem, i.e. it doesn't open those CR2 files created with RAW+JPEG mode on.

Edit #2: I now noticed that the RAW photos exported from my camera have the exact same size as the corresponding JPEG files. So the problem must be in the camera or the memory card and isn't related to Lightroom at all.

  • 2
    I doubt that this is the issue, but I have no other good idea at this time. I have a 600D (T3I), and the problem never happened. Maybe the card is too slow and the camera cannot write all of it fast enough? – Aganju Jul 17 '17 at 14:15
  • That's a valid theory. As Adobe's DNG Converter can't read those files either, I must try and find some other program to help check whether the problem is in Lightroom or the files. If no program can open those I guess this is not a Lightroom (or Adobe in general) issue and your theory might be correct. Thank you. – MJV Jul 18 '17 at 6:42
  • Capture One and Silkypix are capable alternatives that could be used to try and open your RAW files, and both have trial versions available. – meklarian Jul 18 '17 at 7:08
  • I tried opening one of the "double" photos in macOS's Photos app in editing mode and choosing "Use RAW as Original". It only showed a totally black image. So I guess my RAW photos are corrupted or not properly saved at all. – MJV Jul 18 '17 at 9:56
2

After I realized my 2014 MacBook Pro has a card reader I tried transferring some test photos to my hard drive, then importing them to Lightroom. Even the ones shot in RAW+JPEG mode now showed sensible files sizes for the raw images (i.e. much bigger than for the JPEGs) and also the import went well.

So it seems the problem is not in the way the camera stores the photos but in the way they are imported to a Mac.

As this post in Apple support forums states:

…according to Apple Support Chat, Canon no longer provides driver or software support for photo transfer from Canon cameras to Apple iMacs under Mac OS X 10.10 Yosemite. I was told by Apple verbatim, "This is a Canon problem and you will just have to wait until Canon comes out with drivers and photo transfer software that works with Mac OS X 10.10 Yosemite."

So I believe my photos were corrupted when I was transferring them from an old Canon camera to macOS Sierra. And since my camera doesn't have a setting for the communication method (from "Normal" to "PTP", as stated in the linked post), the only thing that solves the problem:

Use a card reader to import the photos. Don't use the camera itself.

  • 1
    So introducing a new product (OS X 10.10) that doesn't work with an existing product that did work with the previous version is the problem of the maker of the older product, huh? It sounds more to me like this is an Apple problem. They're the ones that decided to no longer support a piece of legacy hardware. – Michael C Jul 21 '17 at 11:40
  • It definitely sounds like existing support was explicitly removed, making it an Apple problem. But I'm quite happy with the workaround as the card reader is a faster (and IMHO better) option anyway. I don't know why I forgot my machine had one. – MJV Jul 24 '17 at 6:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.