0

I have a Canon 600D, it's on firmware version 1.0.2. I am in M mode. I set AEB to take 3 photos, then go to shoot mode, and select continuous shooting.

I focus, press the shutter, and only one photo is taken. I have to press the shutter 3 times, or hold it down, in order to be able to shoot the bracketed sequence.

Another weird problem is, I can't use the left/right arrows in the Exposure menu (not in menu, not in quick access and all I can do is create a bracket using the main dial). But the left and right arrows should do under/over exposure for me right?

  • The first is certainly expected behaviour. Not instantly sure about the second. – Philip Kendall May 9 '18 at 18:40
  • What does the manual say about these issues? In other words, what is the officially expected behaviour? – remco May 9 '18 at 18:50
  • both problems are addressed in 105 and later pages, they should be working. especially with being able to change the exposure-compensation that is a normal behavior. @remco – senaps May 9 '18 at 18:58
  • @PhilipKendall so, i only should be able to use auto shoot all 3 images using 2 second timer? in that mode, it wait's 2 seconds after shutter button being pushed, and then takes all 3 images. but i have seen video's of same camera doing it in continuous mode too. – senaps May 9 '18 at 18:59
  • looks like that it's normal behavior to not be able to change the compensation in M mode! photo.stackexchange.com/questions/47046/… – senaps May 9 '18 at 19:09
3

Your camera is acting normally as it was designed to do.

I focus, press the shutter, and only one photo is taken. I have to press the shutter 3 times, or hold it down, in order to be able to shoot the bracketed sequence.

It is explained on Page 106 in the EOS Rebel T3i/EOS 600D Instruction Manual.

enter image description here

Under the first bullet point, it could be clearer that you need to "... press the shutter button completely and hold it down until the series is completed, the three bracketed shots will be taken..." Perhaps since we've all been trained to hold the shutter button down fully until after an image is taken to reduce camera shake (haven't we?), it might have been assumed the reader would understand it to be the case.

So, I only should be able to use auto shoot all 3 images using 2 second timer? In that mode, it waits two seconds after shutter button being pushed, and then takes all 3 images. But I have seen video's of same camera doing it in continuous mode too.

The EOS Rebels are all set up this way. So are most, if not all, of the other EOS cameras. There are cameras from other makers that can be set up to take all three bracketed shots with a single shutter push, but Canon cameras don't allow the option.¹ Further, if mirror lockup is being used there is no way to avoid the mirror cycling between exposures, even when using a wireless remote to allow the entire bracketing series with one press of the button!

¹ If there are any exceptions it would only be with some 1-Series bodies or possibly the 5Ds/5Ds R or 5D Mark IV. Both my 5D Mark III and 7D Mark II, as well as my older 5D Mark II, 7D, 50D, and Rebel XTi/400D are all the same as your Rebel T3i/600D in this respect.

In the videos you are watching either the shutter is being held down in 'Continuous' drive mode, a wired remote with a built-in intervalometer set to take a longish exposure (say, two or three seconds) is being pressed once and sending a "shutter button down" signal to the camera for several seconds with the camera in continuous drive mode, or a different camera is being used in the videos.

It might be possible to do what you want by setting an RC-1 or RC-6 wireless remote (but not the RC-5, which can only be used in 2-second delay mode) to the "zero delay" setting so that the first photo is taken immediately when the button is pressed with the camera in 'Self Timer (10 second)' mode.

I can't use the left/right arrows in the Exposure menu (not in menu, not in quick access and all I can do is create a bracket using the main dial). But the left and right arrows should do under/over exposure for me right?

Most Canon cameras do not allow setting an exposure compensation value when using Manual exposure mode. Some models released since mid-2014 do include the option. This currently includes the EOS 7D Mark II, 5Ds, 5Ds R, 1D X Mark II, 5D Mark IV, 80D, etc. but none of the Rebel/x00D/x000D series. The original 1D X also has the capability with a firmware update released in 2014. For your EOS Rebel T3i/600D it's covered on Page 103 of the EOS Rebel T3i/EOS 600D Instruction Manual.

enter image description here

For some suggestions on workarounds, please see this answer to Stopping down in manual mode with automatic ISO?

Also related: Can I use exposure compensation in manual mode with auto ISO on a Canon DSLR?

-1

I discovered, after several shootings with different settings i discovered that aeb will only work with setting mirror lockup not possible! (I read somewhere that the best setting for aeb shooting should be "mirror lockup possible" for the reason to avoid camera shaking when mirror otherwise flips up and down between each shot. But this will obviously not work on my 600d)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.