I am somewhat of a newbee to photography, but I have a Sigma EM-140 Ring Flash with a 18-250mm Sigma lens.

In short, when I use the camera with the ring flash I can't get it to take photos that aren't just completely filled with white.

I have the mode on auto, so I wonder if my camera (Nikon D7000) detects the ring flash? Currently the flash goes off when I take a photo but the flash on the cameras body always tries to open even though the ring flash is on top of it.

  • 1
    \$\begingroup\$ Perhaps there is a better answer but the general guideline is once you have an off-brand flash you need to take control. In any case, in Manual mode for both the camera and flash you should be able to get any exposure you want. \$\endgroup\$
    – Itai
    Commented May 23, 2013 at 15:04
  • 7
    \$\begingroup\$ That ring flash is supposed to support Nikon's TTL features, but your camera is not in the list of supported ones on the Sigma site for that flash. The difference between the D7000 and something like the D5100 may be sufficiently subtle to cause miscommunication with the flash and hence the behaviour. You may want to check with Sigma directly. \$\endgroup\$
    – Joanne C
    Commented May 23, 2013 at 15:46
  • \$\begingroup\$ awesome, i didn't realise it wasn't supported. Thanks \$\endgroup\$ Commented May 24, 2013 at 16:05

4 Answers 4


The camera is in Auto mode and that setting ignores any other flash settings (or even the presence of an external flash.) It will then automatically use the built in flash without prompting, which is what you're seeing.

The flash listed supports i-TTL so it should be fine with the D7000 even if it's not on the Sigma supported camera list (more commonly it not being listed as supported is because the D7000 wasn't available when Sigma did their testing or they didn't test it.) Switch over to Shutter Priority (S) mode and set it for about 1/160. You camera is rated for more but a little headroom doesn't hurt especially with an 3rd party flash.

If it still doesn't work then go to manual mode and use the aperture dial to get the appropriate exposure, start around f/8 and go from there as suggested in the other answer.


1) Always shoot in manual mode when using external flash. This will solve your problem of on board flash from popping up when external flash is fixed.

2) Keep your ISO to the minimum. Set it to 100 or 200 max.

3) Vary your shutter speed and Aperture to get the right exposure.

A tiny hint for beginner in flash Photography: Shutter speed controls the brightness of ambient light in your image. Increasing the shutter speed decreases the ambient light in the image; decreasing the shutter speed increases ambient light. I would suggest you to keep your shutter speed faster then 1/125 seconds at least.

Aperture controls the brightness of the flash.

Keep this in mind and try. :) Happy clicking mate.

  • \$\begingroup\$ the Nikon D7000 has 1/250 max sync speed, so the advice should be not going any faster than that... \$\endgroup\$
    – fortran
    Commented Aug 30, 2013 at 14:55
  • 1
    \$\begingroup\$ Changing the shutter speed will not change the flash exposure except to lose part of the image once the max sync speed has been exceeded. Reduce the aperture or ISO as suggested. \$\endgroup\$
    – James Gray
    Commented Oct 1, 2013 at 22:46

Generally this would be a problem with your ISO setting. You can do a few things to play around:

  • Try manual mode at around f16
  • Set the ISO to 100 or 200
  • Perform a "green and green" reset - hold both qual and +/- buttons

With the ring flash, I'd suggest using a static shutter speed of about 1/160, then dial in the f-stop based on the distance to your subject.


The Nikon D7000 camera model us not listed on Sigma's compatibility table for this ring flash.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.