On my Nikon D7500, the Bluetooth menu is not available and returns the message "This option is not available at current settings". From other answers I assume you have to first connect Wi-Fi to the nearest broadband. Does anyone have any idea how to do this? Or any tips on how to turn on Bluetooth to allow connection to SnapBridge? Many thanks. Peter


It’s your iPhone, not SnapBridge. Go to your iPhone settings. Select Bluetooth, and click on the “i” next to your camera's name. Then click on “forget this device”. Now try pairing your camera throught SnapBridge. It should work.


Try to again reinstal snapbridge on your smartphone. I had the same problem and this worked.

  • have the sameproblem. reinstalling snapbridge did not work for me
    – marc
    Apr 23 '18 at 22:01
  • Thanks for the help. I deleted the SnapBridge software and then reinstalled it and this did the trick. It re-connected to my camera and the Bluetooth function is now operating. Thanks for the help
    – Tom
    Apr 23 '18 at 22:25
  • I uninstalled and reinstalled the app as stated above and now it works fine. I can see what the camera sees on my iPad. You can use iPad as a remote. You can even change the ISO, Aperture and shutter speed from iPad. Don't give up when it works it's awesome. Touringt
    – Thomas
    Sep 20 '18 at 18:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.