I'm looking to solve this issue of trying to get my DSLR read images to put on the memory card from the computer.

Here are the steps to reproduce the issue:

  1. You click a photo
  2. Transfer it to your computer from camera cable or card reader.
  3. Format the card in the camera
  4. Transfer same image back to the card (no edits/modifications done)
  5. Camera refuses to read it.

I'm using a Canon 5D Mark 3 and using Image Capture Mac to transfer images if that helps.


  • The card is a Transcend Class 10 SD
  • The card was formatted inside the camera and nowhere else.
  • The file system remains intact.
  • No sign of image corruption anywhere. Just refusal to read.
  • \$\begingroup\$ If you format the card itself so that it's clean, then move the raw files (assuming it's raw) back to the card, the camera refuses to read? try taking a new photo on the card once formatted and see if it can read that fine, if it can move it to desktop and check if moving that image back causes the same issue. If not it seems the images are the issue, if so it seems the card is the issue \$\endgroup\$
    – Matthew
    Commented Mar 6, 2018 at 11:46
  • \$\begingroup\$ I formatted the card again in camera, took a new picture (raw), didn't touch that one. Moved one more raw file from computer to card (the one taken earlier before formatting) The camera reads the one clicked, throws error for the one moved in. \$\endgroup\$
    – Rish
    Commented Mar 6, 2018 at 11:53
  • \$\begingroup\$ Have you done anything to the images themselves, were they taken from another camera? what is the exact error message that you're getting? \$\endgroup\$
    – Matthew
    Commented Mar 6, 2018 at 11:55
  • \$\begingroup\$ Absolutely nothing done to images. Yes, they were taken from same camera. "Cannot playback image" with a yellow question mark appearing for the said error \$\endgroup\$
    – Rish
    Commented Mar 6, 2018 at 11:56
  • 1
    \$\begingroup\$ It might help to explain why you want to do this. I can't see a reason why you'd want the photos back on the camera. \$\endgroup\$ Commented Mar 6, 2018 at 22:20

5 Answers 5


If any of the following conditions are not met, address them and recheck to see if the problem still persists.

  • The DCIM folder structure on your SD card is intact. (As described by @twalberg.)

  • You are following the file-naming pattern of your camera. All filenames must be capitalized. You may want to double check with Windows or Linux.

  • The files are of types your camera supports (eg, JPG, CR2).

If the problem still persists, then the problem is most likely, that the images have been modified since leaving the camera, as others have pointed out (@HarryHarrison, @salmonlawyer). The most likely culprit is the image-transfer software you are using. Changes it may be making include:

  • Rotation of the image. Use a program, such as exiftran to losslessly rotate the image back to landscape orientation.

  • Removal of the embedded thumbnail. Cameras typically display the embedded thumbnail, not the image itself. You can try using exiftool to embed a new thumbnail. Or you can save as a new JPG in landscape orientation with a new embedded thumbnail.

  • Conversion to an unsupported file format. No other option but to save a new JPG in landscape orientation with an embedded thumbnail.

In the future, use a standard file manager to copy the files directly from SD card to your hard drive. Image transfer software often do not keep original data intact.


I don't have that same camera model, but when I look at the memory card from my 7D Mark II (so same manufacturer, at least, and probably thus a lot of common features), I see a structure like this:

 |       |
 |       \---EOSMISC

Pardon the poor ASCII drawing skills... The path DCIM/100EOS7D is where the images end up, and the top level MISC directory is empty. However, the DCIM/EOSMISC directory does contain a file M2100.CTG that is in an unknown format. It's entirely possible, although I can't state this definitively, because the file format is unknown, that this is some sort of additional metadata maintained by your camera for every shot taken, that would be lacking on images you copied in, which might cause your camera to not notice the additional files. This is purely speculation on my part, though.


Is the file allocation file corrupted by writing a file to the card? Canon uses special sequencing to keep each file unique and to protect them. Writing a file to the card may corrupt the table or write a new table for dos over it.


Image Camera Mac is doing something to the images, try using Finder to copy the files there and back, and see if you have the same problem.

If Image Camera Mac has the option to copy the pictures without deleting them then that would be worthwhile investgating, as it should not exhibit this problem.

  • \$\begingroup\$ I tried doing same with Finder. Issue still persistent \$\endgroup\$
    – Rish
    Commented Mar 7, 2018 at 18:01

Image Capture Mac most likely does something to the metadata of the image, which means the camera does not realize that the image was taken by it, and is a very common occurrence. Since it does not affect editing programs, this is seen as harmless. Ensure that the RAW files are still in .CR2 (or whichever format the 5Diii uses), and try copying them from/to the camera in the file manager instead of an import utility. If this does not solve the issue, there is a problem with the camera firmware, which cannot be fixed as easily.

  • \$\begingroup\$ I don't think Image Capture does anything to the images in any way. At least that's not documented anywhere. I can verify the MD5 checksum of images if required. However, trying to do the same process via Finder also results in same issue. I'm not sure on what your comment on firmware problem is based on. Is that a guess or a known problem or have you encountered the same in past? \$\endgroup\$
    – Rish
    Commented Mar 7, 2018 at 18:03
  • \$\begingroup\$ This is a problem I have encountered on a 700D and a 1200D. In both cases, a firmware update from Canon solved the issue, although I think it was a side effect of reflashing the camera ROM instead of an actual fix from Canon themselves. \$\endgroup\$ Commented Mar 12, 2018 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.