I would like to use external flash with my Olympus OM-D E-M10 (mark I). It seems, however, that flash is simply not working with my camera. I have tried to set flash in camera to fill-in and fully manual mode, but no luck at all. Also I have tried different modes on external flash itself, including fully manual.

The external flash is Neewer Speedlight NW985. The only mode which is working is the wireless one where flash is triggered by in-camera flash.

What I can do to make the flash working? Is OM-D compatible with any hot-shoe flash or not? Which flash should I get if not? Or is my camera just broken? (It is possible, I bought it on ebay)

Also it's interesting that in the moment I connect flash into hot shoe of my camera, it fires. Is this normal?

I am total flash-newbie, please be patient. :-)

  • \$\begingroup\$ Are you sure that the flash works on other cameras? \$\endgroup\$
    – JPhi1618
    Commented Dec 1, 2017 at 20:37
  • \$\begingroup\$ Pretty sure. It's brand new, and when it's off the camera and I press flash button, it flashes, and wireless mode works as well, as I wrote before. Also, maybe important to mention - I have tried my OM-D with old Fomei M-24 flash, which worked with Canon 350D, and it also didn't work. But I assumed, that it was because flash was so old. \$\endgroup\$
    – Firzen
    Commented Dec 1, 2017 at 20:41
  • \$\begingroup\$ So external flash should fire without setting anything special in my camera, or not? \$\endgroup\$
    – Firzen
    Commented Dec 1, 2017 at 20:42
  • \$\begingroup\$ What is the trigger voltage for the Fomei M-24? How much voltage can the hot shoe on your OM-D E-M10 tolerate? Is it possible the hot shoe (and associated electronics) of the E-M10 is fried due to too much trigger voltage running through it? \$\endgroup\$
    – Michael C
    Commented Dec 2, 2017 at 1:01
  • \$\begingroup\$ I don't know exactly, I don't have that flash anymore. But I read it's hunderds of volts. So, yes, it is possible that it's damaged. I will just try to buy dedicated Olympus flash, and then I will see. \$\endgroup\$
    – Firzen
    Commented Dec 2, 2017 at 2:21

4 Answers 4


Is it a 985C or 985N? 985C is for Canon and 985N is for Nikon. Neewer has flashes for Olympus, but I don't think there is a 985 model?

It should work in flash Manual mode (only in flash manual mode), including on hot shoe, on a PC cord, or as optical slave. Camera mode doesn't much matter, A,S,P or M should work, but a non-dedicated flash has to be in its M mode. However you seem to be saying it does not work on hot shoe in flash Manual mode?

The flash foot has one large center pin which triggers it, the same on all brands, and about 3 or 4 smaller pins that are dedicated to the camera brand it is made for. Every brand has different pin arrangements on the smaller pins. Any automation or communication certainly has to be the right brand model.

  • \$\begingroup\$ Yeah, it sadly doesn't work even when I set camera to M mode and flash to manual mode as well. But maybe I am doing something wrong. The flash is for Nikon, but I naively thought it doesn't matter. I will just return this one and buy one for Olympus. Thank you for your help! \$\endgroup\$
    – Firzen
    Commented Dec 1, 2017 at 22:44
  • \$\begingroup\$ I think you would surely want a TTL flash (can still use Manual mode, but you also have TTL available), but make sure it says "For Olympus". There are flashes that say "For Nikon, Canon, Olympus,Panasonic", etc, but those are Manual mode only flashes. If TTL, it can only be compatible for one of them. \$\endgroup\$
    – WayneF
    Commented Dec 2, 2017 at 16:44
  • \$\begingroup\$ Well, so I got Neewer Speedlite NW320, which says "for Panasonic Lumix Olympus" on package, and it still doesn't work. It behaves exactly the same as last flash - just not a single fire even in M mode set on camera and flash.. Any ideas? :-) \$\endgroup\$
    – Firzen
    Commented Dec 10, 2017 at 0:22
  • \$\begingroup\$ Does the cameras internal flash work? The camera has a flash mode setting of Flash Off. Make sure that is not on.. \$\endgroup\$
    – WayneF
    Commented Dec 10, 2017 at 13:26
  • \$\begingroup\$ Yes, of course the flash is ON, and internal flash works perfectly. \$\endgroup\$
    – Firzen
    Commented Dec 10, 2017 at 20:06

I experienced this exact issue on my EM10-iii and it turned out to be mechanical in nature. In my case, I was trying to fire a Yongnuo YN560-III and a RadioPopper JRx, the first is a low-voltage flash the second is a low-voltage radio trigger. Both only have a single center pin.

I couldn't get either the flash or the radio trigger to fire directly on the camera, despite all the flash settings etc. Then I tried putting a hotshoe adapter on the camera and attaching the flash and trigger to the adapter. The adapter I have is a LumoPro Universal Hot Shoe Adapter II (not sold anymore, replaced by JJC Standard Hot Shoe Adapter).

When I use the adapter, the flash and radio trigger fire no problem. Looking at the bottom of the adapter, it has a much larger center pin with a substantially larger diameter than both the flash and the radio trigger. This is what the adapter looks like. hotshoe adapter

It also has a plastic base instead of metal. Under suspicion that this was shorting the other 4 pins, I tried taping them off but the problem did not change. Also to note, I use these accessories on my Canon all the time and it also has the 4 extra pins for TTL and I don't need to tape those of. It's absolutely impossible for the center pin of the flash to touch anything but the center pin on the hotshoe due to the guide-rails.


What I can do to [get] the flash working?

Take it out of slave mode.

The only mode which is working is the wireless one where flash is triggered by in-camera flash.

This means that your flash is in a slave mode. That tells the flash to ignore any signals on the hotshoe, and to listen to either an optical sensor (if it's an optical slave mode) or the internal RF receiver (if it's in a radio slave mode on a flash that has this; your Neewer doesn't).

When you try to use a flash on a camera hotshoe, it has to be set to "listen" for signals on the hotshoe, and that means being out of any off-camera slave modes.

Is OM-D compatible with any hot-shoe flash or not?

It is and it isn't. It's fully compatible with any four-thirds flash if you want TTL/HSS and camera/menu communication.

But it's also partly compatible with any ISO-compatible flash if all you need is to fire the flash in sync with the shutter. But with this type of operation, you can't do anything else from the camera. You have to manually set the power level, you can't use TTL or HSS, or change any settings on the flash via the camera menus. It has much more limited usefulness.

As far as I can tell, that Neewer model only comes in Nikon and Canon flavors, so on a micro four-thirds camera, you won't get anything but firing in sync, because the camera hotshoe isn't speaking the same language (electronic signal protocol) the flash understands.

Which flash should I get if not?

If you want full TTL compatibility, you need to look for a flash that's compatible with Olympus/Panasonic (e.g., an FL-600R/FL-360L [same flash, made by Panasonic, rebranded by Olympus] or a third-party flash (e.g., Godox, Nissin, Metz, Meike, etc.) that does Olympus/Panasonic TTL.

Also it's interesting that in the moment I connect flash into hot shoe of my camera, it fires. Is this normal?

If both the camera and the flash are on, yes, this can happen. The firing signal is a simple short between sync and ground. As you slide the flash in, the sync pin can hit a "live" connection, and that will fire the flash. You should have the flash turned off when you put it onto the hotshoe, and only turn it on after it's been secured in place.

See also:


I was having the same issue with my Panasonic GX9 and my Neewer Speedlite NW320. All you have to do is turn off the silent mode for your shutter. Once that is done - your flash will work - at least that's what worked for me.

  • \$\begingroup\$ However, the OP mentioned the built-in flash is working for wireless triggering. In electronic shutter/silent modes, flash tends to be disabled altogether. \$\endgroup\$
    – inkista
    Commented Mar 18, 2019 at 4:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.