0

I recently installed Lightroom CC 2015 6.1 on my computer, but when I start the start the software I get a dialog with the message "Lightroom catalog cannot be opened because another application already has it opened.". I have installed and used it in the past but have never got this error before.

2
  • Try to restart the computer and run LR again – Romeo Ninov Nov 21 '17 at 12:04
  • @Romeo, I have restarted my computer but the error doesn't seem to go away. – user69925 Nov 21 '17 at 12:31
3

Have you checked on Google? This was the first result:

Solution: Delete the catalog lock file

To resolve this issue, do the following:

Close the Lightroom application. Go to the folder where your catalog file [yourcatalogname].lrcat is saved. By default, Lightroom saves catalogs in the following folders:

  • Windows: \Users[user name]\Pictures\Lightroom
  • Mac OS: /Users/[user name]/Pictures/Lightroom

Move the [yourcatalogname].lrcat.lock file to the Trash (Mac OS) or Recycle Bin (Windows), if it is present at this folder location.

Caution: Do not delete or move the main [yourcatalogname].lrcat file.

Relaunch Lightroom. If your catalog opens successfully, you can empty the Trash (Mac OS) or Recycle Bin (Windows).

Source: https://helpx.adobe.com/lightroom/kb/lightroom-error-catalog-cannot-be-opened-lrcat-lock.html

2
  • 1
    Thank you, this solved my problem. Apparently, the Lightroom folder from the previous install was still on my computer. – user69925 Nov 21 '17 at 13:22
  • I have had this issue before and solved it thusly, however this time it isn't working. The lock file is in the recycle bin and no new one has been created, but LRC still won't open. It's acting like the lock file is still there. Any thoughts? I know I can just reboot, but I always like to know why something snagged (it's the PC tech in me). – AVLien Apr 17 '20 at 17:06
0

When a program opens a file (such as your catalog) it often locks the file so other programs can't modify the file while the first program is using it.

If the program crashes before unlocking the file the file is basically in an orphaned locked state. The easiest way to unlock the file is to restart your computer.

There are various programs that can unlock a file, but it's sketchy if you don't know what you're doing.

1
  • 1
    but I have restarted my computer but the error doesn't seem to go away. – user69925 Nov 21 '17 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy