5

Is Lightroom Classic significantly slower than when it was just called Lightroom CC? I recently built a new computer with a Ryzen 1920x processor, 32GB RAM and dual Samsung 960 Pro SSDs. I also updated Lightroom to the newest version (Lightroom Classic) at the same time. I expected it to scream but everything about it seems much slower than it was on the four-year-old laptop I replaced. Building 1:1 previews for a couple dozen large TIFs has currently been running for 7 hours and is only about 1/3 done. While LRs processor usage is under 5%. The interface is incredibly slow too. Changing modules takes a long time. Grabbing a crop handle will take a few seconds to start responding. The whole screen will occasionally go black and show me the busy spinner. Nothing loads any faster than it did on my old laptop; maybe slower.

What gives? Is Lightroom bottlenecked by it's own code and simply unable to take advantage of fast processors and SSDs? Or is something wrong with my computer? PT GUI and Photomatix both seem much faster. Photoshop too but I haven't used it much yet. It's frustrating to have spent this money on a powerful computer only to have LR act like it's running on a out of date budget PC.

  • 1
    For what it's worth, I am extremely disappointed with its performance when I upgraded to a 2015 Macbook Pro with a SSD, to the point where my old 2011 MBP with an HDD was much faster for Lightroom – laurencemadill Nov 13 '17 at 12:59
  • 6
    I'm voting to close this question as off-topic because this seems to be a problem with this user's machine or configuration. 5% of CPU usage is a single core maxed out + a couple of background tasks. – James Snell Nov 13 '17 at 13:27
  • @james snell where should I go to ask about lightroom performance? – dev_willis Nov 13 '17 at 19:32
  • 1
    Since the CPU isn't being used, it is most likely the disks holding you back on the building previews as the graphics cards are not likely to be used for that step either. Have you tried a reliable brand of SSDs? Or maybe it is the formatting, are they set up as RAID 0 or 1 or independent? – Itai Nov 13 '17 at 19:55
  • The SSDs are both Samsung 960 Pros, which are the fastest drives currently available on the consumer market. They're independent drives: one is the system drive and the other is a data drive. Both 512GB. Resource Monitor indicates that they are basically idle along with the rest of the system while LR is choking like it was totally out of all system resources. – dev_willis Nov 13 '17 at 20:39
2

A few versions ago, I had to disable my graphics card because of issues like what you are describing.

Under Preferences/Performance there is a check box.

Probably not the issue but worth a try. If that does speed things up then check out: https://helpx.adobe.com/lightroom/kb/lightroom-gpu-faq.html and make sure the driver is current: https://helpx.adobe.com/lightroom/kb/lightroom-gpu-faq.html#gpu_driver_troubleshoot

  • Thanks for the response! I have tried disabling that setting but it made no appreciable difference. My graphics card is a GTX 1050 Ti SC. Resource Monitor indicates that it too is basically idle. When this setting is checked usage is around 6-8%. It drops to 2% when I uncheck it. – dev_willis Nov 13 '17 at 20:42
0

What is your computer doing at the same time that you are trying to work your magic?

You are describing a situation where your system is processing unnecessary clutter which is bogging down your progress.

Eliminate the system tasks and other operations that are interfering with your work flow. If you are using a MAC, this can be monitored by "Console" software. There is equivalent diagnostics in Windows and Linux.

You might have TSR's that are grinding away and tying-up system resources necessary for Lightroom to work unhindered.

  • In my case, it didn't matter what was running. The update they released a month or two ago made a significant different though. It's much faster now. – dev_willis Apr 17 '18 at 16:54
-1

have the same problem - booting in safe mode (win7) solves the issue.. i belive it has to do with bitdefender and/or other plugins installed. i just tried safe mode boot and works as it should, with all the downside of not using anything else..

  • Safe Mode isn't recommended for day to day use of a computer so this isn't a suitable answer. Many important features are disabled, eg the ability to use the internet, antivirus scanning software, suitable graphics resolution etc – laurencemadill Nov 23 '17 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.