1

In a previous question, I asked about my exposure problems and there I found out that my lens cannot adjust the aperture/aperture blades. Every time I try to adjust the aperture to a higher number my and take a picture, an error comes up. I tried to check the lens and I saw that the aperture didn't change, thus giving me an error. Sometimes, the aperture blades also gets stuck and doesn't go back to its original position. I've tried cleaning the contacts of the lens and camera but the camera and the lens still loses contact. I also tried borrowing another lens, adjusted the aperture and the camera still loses contact with the lens. It seems my camera loses contact with the lenses every time I change the the aperture, though it works fine if I use the smallest available aperture. What is the possible cause of the lose of contact?

Camera: Nikon D90

Lens: AF-S DX NIKKOR 18-55mm f/3.5-5.6G VR II

Thanks in advance!

  • Judging by my experience with Canon lenses, it is probably a bad ribbon cable inside the lens, but I'll let someone more familiar with Nikon's lenses confirm that. – dgatwood Nov 5 '17 at 14:53
  • Seems to happen with other lenses as well, so not a lens issue. Let's ask a basic question : is the camera in an exposure mode that lets you control aperture ? – StephenG Nov 6 '17 at 7:15
  • @dgatwood Nikon (with the exception of a few very recent higher end lenses) use a mechanical, not electrical, connection to control the aperture diaphragm. – Michael C Nov 6 '17 at 9:10
  • Don't you mean 'smallest available f-number?' (i.e. the widest available aperture) – Michael C Nov 6 '17 at 9:12
0

It sounds like you've got an issue with the mechanical lever in the camera body that stops down the aperture in the lens via a mechanical linkage.

Nikon lenses (with the exception of a few very recent higher end lenses) use a mechanical, not electrical, connection to control the aperture diaphragm. With the vast majority of Nikon lenses the electrical contacts are only for communication telling the camera what lens is attached and what the maximum aperture (lowest f-number) is. When it's time to actually stop down the aperture diaphragm, the mechanical lever does that. Or at least it is supposed to do that.

The reason you don't get the error at the lens' maximum aperture (lowest f-number) is because the lever doesn't have to move anything for the aperture to be wide open since the act of mounting it on the camera should open it up all the way.

  • Is there a way to fix this kind of problem? – GHMCA1216 Nov 6 '17 at 12:55
  • @GHMCA1216 To do it correctly probably requires a trip to a Nikon Service Center. It's a fairly common problem on Nikon cameras. Their technicians are familiar enough with the cameras that it is more efficient and cost effective to replace the bent lever with a good one. Of course that requires almost total disassembly/reassembly of the camera AND Nikon does not sell internal replacement parts to consumers (or even non-authorized camera repair shops), so it's not really something you can replace yourself. You can try to bend it back, but you'll likely make things worse. – Michael C Nov 7 '17 at 5:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.