1

Lightroom shows jpeg files with a purple cast, but the photos appear normal outside of lightroom. I have included a screenshot which includes the same photo in both Windows Photo Viewer and Lightroom.

Some possibly relevant info:

  • The camera is a 10 year old camera, so it is not related to an unsupported new camera model etc.
  • The images are all jpegs, so it is not related to a raw conversion problem (this is the common google result)
  • The images appear fine in both Photoshop and Windows photo viewer.
  • This is a new installation of Lightroom and Windows 10
  • Photoshop complained "The monitor profileSamsung Natural Color Pro 1.0 ICM appears to be defective. Please rerun your monitor calibration software." when it started, but it still shows the files fine (i.e. without the purple cast)
  • The same jpeg files (same camera and settings) are known to import fine on Windows 7 (with the previous-to-current version of LR) and on my macbook (both current and previous versions of LR).

Example of the problem.

  • 1
    the "complained about something " might be important. please post your various profile settings and an example jpg. – ths Oct 25 '17 at 8:08
  • 1
    Possible duplicate of Why is Lightroom not rendering what I see in every other JPG viewer? – feetwet Oct 25 '17 at 16:07
  • I followed the steps that @feetwet linked to, and it resolved it completely. Feel free to write up an answer. Strange that PS complained, but worked fine, and LR didn't complain, and had a problem. – RoG Oct 25 '17 at 17:38
  • @ths I added the text for the PS message, in case someone finds that helpful while googling. – RoG Oct 25 '17 at 17:38
  • 1
    Yeah, this happens far too often. Posted essentially my same answer here to help anyone who lands here via search. – feetwet Oct 25 '17 at 17:46
2

This usually occurs due to improper OS-level color management setting. Following these instructions will fix it:

Windows

  1. Close Lightroom.
  2. Go to Start menu > Control Panel > Color Management.
  3. Click the Devices tab if it’s not already selected.
  4. From the Device pop-up, select your monitor. If you have more than 1 monitor connected, pressing the Identify monitors button will display a large number on screen for identification.
  5. Check the ‘Use my settings for this device’ checkbox.
  6. Make a note of the currently selected profile, which is marked as (default). If there isn’t an existing profile, you can skip this step.
  7. Click the Add button.
  8. In the Associate Color Profile dialog, select sRGB IE61966-2.1 (sRGB Color Space Profile.icm) and press OK.
  9. Back in the Color Management dialog, select the sRGB profile and click Set as Default Profile, and then close the dialog.

Mac OS X

  1. Close Lightroom.
  2. Go to System Preferences > Display.
  3. Select the Color tab.
  4. Press the Calibrate button and follow the instructions.
  5. Turn on the Expert Options and calibrate to gamma 2.2.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.