28

I'm using the Huawei P10 with its Leica camera.

Recently I noticed very visible large block-like artefacts in the sky. These artefacts are present on some pictures, but not on all, and they are already present in the photos before editing them.

Here are some examples:

This picture was taken with 1/978 seconds, f/2.2, ISO 50, resolution set to 8 MP:

enter image description here

This picture was taken with 1/1220 seconds, f/2.2, ISO 50, resolution 8 MP:

enter image description here

Taken with 1/797 seconds, f/2.2, ISO 50, resolution 8 MP:

enter image description here

Note how the artefacts follow the contour of the trees.

What could be the reason for such artefacts? Is something with the camera hardware wrong? Or is it a bad post-processing by the camera app?

As I said, the artefacts occur on some pictures, but not on all. The pictures where they don't occur are completely fine and have a smooth sky.

EDIT

Here is a good picture for comparison. I took it just 1 minute after the first of the above pictures. The brown field on the left side is the same as the field in the foreground of the first picture above.

In this picture the sky is rendered correctly, there are none of these artefacts. And basically same scene, taken just 1 minute after the one above which has the artefacts.

This was taken with 1/952 seconds, f/2.2, ISO 50, 8 MP resolution.

enter image description here

So, is it likely that it's a sensor problem, if some pictures are still completely ok?

EDIT 2

I took some more shots and finally found out what's causing the artefacts: the digital zoom. All the pictures that are taken without zoom are ok, and most (but not all) with any level of zoom have these artefacts.

The Huawei P10 actually has, what it calls, 2x Hybrid Zoom, a digital zoom which is supposed to allow the level of detail of an optical zoom up to a level of 2x, by the means of two separate lenses. I don't know exactly how it works, but there seems to be something messed up in the current implementation.

As mentioned, all the pictures taken without this hybrid zoom are ok, so the bug must be in the implementation of this zoom. I will try to report this to Huawei (build number VTR-LR29C636B151).

  • 1
    Does the camera have raw possibilities? Take one pic in raw and one in jpeg to confirm it is jpeg artifacts (or not) – PlasmaHH Oct 12 '17 at 8:07
  • Did not you rescale or re-compress the image? Are the uploaded images exact bit-to-bit copies of what the camera produced? It is strange that the artifact boundaries are not aligned with the actual JPEG block boundaries. --- Please check if similar artifacts can appear when shooting to RAW and also check the artifacts when saving the photos at the native resolution of the camera. I think it is higher than the resolution of the images above - 1632 x 1224. – pabouk Oct 12 '17 at 16:51
  • There could be something broke in the automatic white balance algorithms that cannot decide on the colour temperature of the sky as it is almost the same everywhere. It would be interesting to see which RGB or RAW colourspace component is mostly/exclusively affected by the likely software bug. Could be some exotic voltage regulator failure but ask about that on electronics.SE. – KalleMP Oct 13 '17 at 7:18
  • @pabouk Original resolution produced by the camera was 3264x2448 (8 MP), I rescaled the images by 50% to upload them here. I found out that the problem is caused by the hybrid zoom of the camera, which seems to work by combining the information of the two separate lenses and sensors of the phone. Interestingly, at the native resolution 20 MP of the main camera and in RAW mode, the hybrid zoom is disabled, so the problem does not occur there. – weibeld Oct 13 '17 at 11:37
  • @weibeld So probably there us a flaw in the algorithm which combines the image from the two cameras for the Hybrid Zoom. --- Unrelated - One positive thing is that when you decompose the image to HSV the hue channel is not affected so you can correct the artifacts just in the saturation and value channels. – pabouk Oct 13 '17 at 12:15
29

I would suggest that it might actually be a sensor fault (or firmware bug).

My reason for suspecting this rather than JPEG artefacts or banding is that the surrounding sky has exactly the same gradient but is rendered correctly. Also, JPEG artefacts would tend to be noticed in areas of higher detail, but those look great.

If this only tend to happen in large flat areas like that example of sky, then it may be a bug in the JPEG codec in the camera's firmware. It may be skipping encoding blocks based on estimating that they contain no detail, but that skip algorithm may be over-eager. Or, since this is happening in a highly-saturated part of the image, it may be a fault in the camera's internal color space conversion. Either way, this shouldn't happen in a normal camera.

If corruption like this happens regardless of content and always tends to be in the same area of the sensor, I would suspect a hardware sensor fault.

If it does have a RAW mode then this may give you more information about where this problem lies but probably won't help you solve it, unfortunately...

  • I think the corruption depends on the content, as I haven't seen the problem in pictures with anything else but blue sky on the top. In some pictures the artefacts even follow the contours of the non-sky content. Some pictures are ok, as seen in EDIT of question. So, shouldn't be a hardware bug. Also good to know that it's not typical JPEG compression artefacts or banding noise. I also think that, as you say, the problem might be in the camera firmware or camera application, maybe some internal optimisation gone wrong, probably introduced by a software update. – weibeld Oct 12 '17 at 10:53
  • It could also be due to some other algorithm in the pipeline. Noise reduction algorithms tend to have problems in the sky due to smooth gradients making small changes much more noticeable. Or it could be image fusing that goes wrong for HDR or stabilization. Not sure exactly what the SW pipeline does in that phone. – Leo Oct 12 '17 at 15:03
  • 1
    The problem photos posted also show extreme sharpening, so if the good shot was taken with the same post-processing settings, this also points to a bug. – Yorik Oct 12 '17 at 20:52
  • I accept this answer, because it comes closest to the actual problem, see EDIT 2 of the question. – weibeld Oct 13 '17 at 11:26
  • 1
    Probably a hardware issue, tbh. It looks like intermittent offset pickup noise on the sensor line readouts - could be a bad solder job on the motherboard, a flaky sensor, whatever. – J... Oct 13 '17 at 12:16
22

These look like JPEG compression artifacts, possibly caused by picking a lower-quality setting in the camera settings. On many cameras there's e.g. a Fine JPEG mode and a SuperFine mode, or something similar to that. Select the higher-quality option, or better yet, shoot RAW...

  • 1
    It's the smartphone camera of the Huawei P10, which has been co-fabricated by Huawei and Leica. There seems to be no setting for the JPEG compression mode. RAW is possible, but means more post-processing work. I will do some experimentation in which circumstances the artefacts occur, and in which not. Could it have something to do with the resolution, whether I shoot 8 MP or 20 MP? – weibeld Oct 11 '17 at 17:58
  • 3
    @weibeld If there are no JPEG compression settings, consider checking for software updates for the phone. Looks like a FUBAR'd software package to go along with that camera. – Calyth Oct 11 '17 at 18:10
  • 7
    @Calyth I can try with an alternative camera app and see if the artefacts ever occur there. – weibeld Oct 11 '17 at 18:25
  • 23
    I think this is a red herring. It looks like JPEG artifacts at first glance, but they're on a completely wrong granularity. – Michael Borgwardt Oct 12 '17 at 7:13
  • 4
    If they're compression artefacts, it's more like a bug in the encoding routine than inherent to the jpeg structure. I've seen similar things in mjpeg at high frame-rates (for the cheap processor), especially the blocks on two or three length scales – Chris H Oct 12 '17 at 11:06
3

Analysing them with ULead Photoimpact and simply experimenting with the brightness/contrast/gamma, I see some quite unusual artefacts and note new artefacts. Indeed, on your first image there is a faint but quite noticeable Fata Morgana mirage just above the hill contour in what at first glance looks simply like a thin cloud. First image highlighted, 75pc cont

I note also that the edges of the phenomena are not clearly defined (ie: soft) and in some case fractionally off vertical which tends to rule against hardware/firmware and to a large degree even compression artefacts. enter image description here

The spread of noise is different between the two defective images and the good image (when winding up contrast to 100% and reducing brightness), suggesting to me that some process has definitely occurred, perhaps something as subtle as anti-shake, auto exposure or some unintended edit.

These two pics demonstrate that.. enter image description here enter image description here ..(both -50% bright, 100% contr. Expand the image to see just how much more blocky the first is overall than the second).

Finally, there are some extremely faint artefacts even on the final image.

Conclusion -- edited (unintentional I assume, probably by an unwanted after-process), or mirage.

Keep the camera .. it might be trying to tell you something.

  • 1
    Great analysis! I posted a new picture with particularly many artefacts, and there you can see how the corruptions follow the contour of the adjacent high-detail area (trees). The problem seems to be related to the hybrid zoom of the camera, which works by merging two separate images. So, apparently there is a fault in the image combination algorithm. – weibeld Oct 14 '17 at 15:03
  • @weilbeld - Oh wow! That explains it.. Yes, it fascinated me so I had to dig into it.... – www-0av-Com Oct 14 '17 at 16:49
1

Just called Huawei Support - they told me that its a hardware fault and has to be checked in repair center. Got a P10 here with exact same artifacts in the sky.

  • Good to know. Huawei told me the same, and that it's covered by their warranty. – weibeld Feb 22 '18 at 22:18
0

Were the photos taken out in the open? They look like they could be reflections from an awning or vehicle roof.

  • Yes, they were all taken in the open. And only some have these artifacts, maybe 50% of the pictures with a clear blue sky. – weibeld Oct 12 '17 at 0:54
  • 3
    I think that because the borders are perfectly parallel to the photo borders, it is more likely that it are artifacts, and not what you described. – Karlo Oct 12 '17 at 9:09
0

Does this happen with low light photos as well? Does this only happen near the top of the photos? Did this camera/phone always produce photos like this or is this an issue that just appeared after you've had the phone for a while? If so to the last question have you tried wiping the phone and setting it up as new? (not restoring from old data as something may be corrupt). As Twalberg has said above it does appear to be JPEG compression artifacts. However why the pattern didn't travel across the sky horizontally to the left I don't know. The sky in this area appears to be the same gradation of blues as where the "artifacts" appeared. I believe if this truly was JPEG compression artifacts, it would have been applied to the entire photo and not just selective spots. On that note I'm willing to bet there's something either wrong with the camera or the software doing the compressing on the phone (camera software).

  • Actually I first realised this problem one week ago, and in earlier photos with blue sky, I don't see these artefacts. In low light photos, like sunsets, it doesn't happen either (until now). It always happens near the top of the photos, and so far only in photos that have a homogeneous blue sky at the top. However, not in all of them as seen in the EDIT of my question. I don't know if the camera app was recently updated, but this would be a possible explanation, that the problems were introduced by a software update. – weibeld Oct 12 '17 at 10:32

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.