3

I am having this issue with my Canon raw files.

I went to download images from my memory card to my computer, and when I opened my memory card to transfer the images, I realized that they were saved as CR0 and not as CR2. I cannot open the files in any application.

This is the first time that this is happened to me.

  • 4
    Are you sure? Canon RAW files have always been .CRW (very old files) or .CR2 (new files). Exactly which camera are you using, and what happens if you rename them to CR2? – Philip Kendall Sep 20 '17 at 9:03
  • I'm using a Canon 5D Markiii. I tried renaming them and only a few converted back to where I could import them to Lightroom. – Lucio Sep 20 '17 at 9:05
  • 1
    Let's be clear here. Changing the filename extension never converts a file format. The filename extension is just an indicator in the filename as to what file format is in question. You need to determine the file format of these .CR0 files, and you need to determine why this filename extension has been applied. – osullic Sep 20 '17 at 9:13
  • 2
    Can you post a sample of one of the files that won't open? We might be able to look at the contents and get a better idea of what's going on, but that's very, very odd. I've never had that happen on my 5D Mark iii. Are you using any third party firmwares? – AJ Henderson Sep 20 '17 at 13:44
  • 1
    By chance, is your Canon running modified firmware? I.e., are you using CHDK or MagicLantern? – scottbb Oct 21 '17 at 2:06
1

It doesn't sound like you have raw files at all, but on Linux there is a small utility called (imaginatively) "file" which identifies file types based on magic numbers at the start of the file.

If you don't happen to be lucky enough to be running Linux this question and answers lists some alternatives.

  • Thanks for all the comments, everyone. I used a SanDisk 8gb Ultra card. It is my own card, bought it new at a camera store three years ago. Only used it woth my 5d. Strangest thing is, fifty images were restored back to CR2, when I changed the name. I know that changeing the name won't convert the file format, but in this case it did. I'm going to keep on searching the web. I tried to upload an image, but for some reason it won't post. – Lucio Sep 21 '17 at 2:53
  • 3
    Changing the extension on the name will not affect the contents of the file, but it might make the files recognizable to the operating system and to the programs used for display and conversion. – user39557 Oct 21 '17 at 3:12
-1

Have you tried to change the filename back to .cr2 extension? It's possible the extension was saved incorrectly for some reason.

  • 3
    This has already been covered in the comments. – Philip Kendall Oct 29 '17 at 18:23
  • 1
    Cookra, responding rudely to Philip isn't necessary. He was simply pointing out that the answer had been covered and doesn't work, which is probably why you were downvoted. He was trying to be helpful. That said, I do believe this is an answer. It may be incorrect as established, but it's better to have it as it's own answer so it can be acted on properly. – AJ Henderson Oct 30 '17 at 12:17
  • Nothing to do with being rude really, if it was to be a friendly / polite note to say it has been covered in the a previous comment, then just add a comment.. Down voting is a little keen wouldn't you say.. Either way, had the same issue with my Canon 5d a few years back, changing the file name worked as the compile structure wasn't harmed. For me the problem happened only once but we were shooting in cold conditions.. So let's be clear, simply pointing out is not down voting someone new to the group.. Hey ho, such as life – Cookra Nov 1 '17 at 0:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.