I have a Nikon D90 that had an unfortunate fall. Since then, if I have it in any mode except manual it throws up an Err.

If I use it in manual and follow its exposure guide in the view finder it vastly over exposes (white). However, if I ignore the exposure (let it say the exposure is way too dark), best guess then adjust based on the preview for that pic, it works.

So it seems the either: a) the exposure sensor is broken; b) that the sensor isn't actually being exposed to light through the lens and is only, eventually, being exposed to some incidental light through the view finder - hence the white out; or c) something in the electronics that interprets the sensor.

Given the autofocus still works (in manual) and I can see through the viewfinder just fine I assume the mirror, focusing screen, and autofocus sensor are all functional. But the fact that it does eventually read some light suggests it is still 'on'/responding/plugged in, perhaps?

Can anyone think of anything else I could try before I try before attempting to get into the prism? :s

  • Are your two lenses AF-S with AF motors in the lens or AF that require the AF motor in your D90 body?
    – Michael C
    Aug 29, 2017 at 3:08
  • @Michael Clark One of them is a AF-S (Nikkor 18-70mm) the other I am unsure. The problem doesn't seem changed by which lens I have on. Extra info: It throws up the FEE error if I have the aperture ring not in the smallest position - some communication between the lens and body?
    – The_Tams
    Aug 29, 2017 at 5:20
  • It should give an fee error when the aperture ring on a 'D' lens is not locked in the narrowest position. That is normal. The difference between the AF-S and AF lenses is that one uses electronic communication regarding AF and the other does not.
    – Michael C
    Aug 29, 2017 at 8:41
  • I looked up the other lens and it also has an inbuilt motor (Sigma 70-300mm f/4-5.6 APO DG Macro Lens for Nikon AF-D ) which I suspect means it communicates electronically re: AF. Both lenses still Autofocus with no problem and the AF screwdriver coupling (at 6:30) retracts and extends with the AF/M control as it should. I thought the FEE may indicate that the lens was still 'communicating' the aperture with the camera. I checked the aperture control leaver and it looks fine. It also appears to work correctly when the shutter operates. I will update if I find a solution.
    – The_Tams
    Aug 29, 2017 at 20:31
  • The 'fee' error is the way your camera is supposed to work. Anytime a lens with an aperture ring is not locked into the narrowest aperture when used with the D90 it is supposed to give an 'fee' error. This is so that the user will lock the aperture ring of such lenses at the narrowest aperture so that the camera, rather than the aperture ring, can control the aperture setting, albeit via the clunky mechanical connection left over from the 1950s.
    – Michael C
    Aug 30, 2017 at 7:20

2 Answers 2


It could be just about anything.

Your Nikon D90 has a 420 pixel RGB light meter that is essentially a second, very low resolution image sensor. The chances are pretty high that the connection between the light meter and the camera's main processing unit has been damaged. It could be something as simple as a ribbon cable coming unplugged, or as devastating as a crack in your camera's main PCB.

When you are in Manual Exposure Mode and the camera seems to be getting a very weak light meter reading, it could be noise generated by the electronics at some point in the connection path between the light meter and the camera's CPU. Just as a high resolution CMOS sensor and its associated electronics can generate 'dark current' that manifests itself as read noise, the much lower resolution CMOS metering sensor and its associated electronics can as well. If the break in communication is between the light meter and the electrical components that amplify the signals from it, then the noise generated by the amplifier might be what your camera's CPU is interpreting as a very weak signal from the light meter.

As this answer suggests, it could also be a communication error between the lens and the camera. Such an error may or may not be associated with physical damage at the interface between the camera and lens. It could also be occurring anywhere in the electronic path between the lens contacts and the camera's CPU.

  • Its seems odd that is could be this catastrophic given the camera is still taking great pictures. The problem does seem localised to the chain of things that must work for the camera to correctly meter light. The manual exposure does change in a way that looks normal when I adjust the shutter speed, iso or aperture, but it is way off - I have been trying more tonight.
    – The_Tams
    Aug 29, 2017 at 5:24

Sounds to me like you may have a problem with the electronic aperture linkage between the lens and the mount - maybe one of the pins isn't making proper contact.

If you're getting an error in every meter mode except manual, that suggests that the camera doesn't know what the aperture's supposed to be, which suggests the lens isn't managing to tell the camera what the maximum aperture is. That may also explain why your manual metering is way off - if it's assuming that it's wide open setting is at f32 - or whatever its smallest possible number is as a default, - then that would explain why it overexposes.

Since the camera doesn't particularly care what the brightness currently is for getting a metering mode to work (as opposed to giving an error) that suggests its probably not either of your ABC options - the camera has no way of knowing whether the light value it's reading is correct, so there's no reason why it should give an error. On the other hand, if it's not getting a maximum aperture value back - and it knows that it isn't - then it should give an error for any of the metering modes where it needs to know what that is (basically, most of them except manual)

Might be worth checking that the lens mount contacts are working OK. (and may be worth trying a different lens to see if it's a mount/internal or lens problem).

  • Hi JerryTheC, Thanks! I have tried both lenses I own and it has the same problem so I decided it was the camera body not the lens. I also tried cleaning the contacts, and no go either. It would make sense if I have somehow damaged the connection as the lens on the camera was what hit the ground - shattered the filter. I do have a dysfunt D80 body around I can take a look at to see if I see any physical differences between the two. I didn't see anything obvious, but I hadn't looked closely before it was damaged. Is there any other way to diagnose mount connection damage?
    – The_Tams
    Aug 29, 2017 at 0:07
  • If you have the same problem with a different lens that wasn't dropped, then as you say, that points at the camera being the problem.
    – JerryTheC
    Aug 29, 2017 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.