2

At least, that's what it seems to be. Whenever you want to advance the film on this model, you have to load the film, close the door and press the shutter release button once. After that, it should advance until the counter shows a '1'. When I turn on the camera by sliding back the lens cover, it automatically starts advancing and taking pictures until my roll is done, at which point it sits and beeps until you rewind the film or shut the lens again to turn it off. Opening up the top half where the shutter is located revealed nothing unusual (at least, it seemed normal to me, I don't know anything about cameras), and I couldn't open the bottom half because of one screw refusing to come loose. Aside from carving a hole around said screw, what can I do to fix this?

EDIT: When I first bought this camera, I tried using it before putting film inside to make sure it worked. I don't remember if it started continually advancing right after that, but it started to do so before I fully removed battery corrosion and added film. Also, it sounds like it's constantly taking pictures when both advancing and rewinding (the lens also keeps trying to rotate in one direction, but falls back into place at the same time as the noise).

EDIT 2: With no responses, I tried to find the problem myself after removing the last screw. While looking at the parts to try to find the problem, I accidentally bumped a piece and now it's jammed somewhere inside. This is probably going to have to be sent to an experienced repair person or just dumped forever.

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • I’m having the same problem with a Ricoh I just bought. Did you ever get it fixed? How? – Monica Apr 4 at 21:43
0

The Ricoh FF-3AF is a compact autofocus camera released in 1982. Your model could be over 30 years old!

The shutter release is electronically controlled. Your problem is going to lie in one of two places:

  • The shutter release button is stuck. The release appears to be completed by closing a circuit. Perhaps the button itself is stuck such that, when the top is on the camera, it is pushing down. Test this by attempting to load a role with the top off and the shutter release mechanism clearly disengaged.
  • If the problem persists, the electronics have gone. Either a problem with the button mechanism itself or somewhere else in the circuity. If this is the case, the camera is junk (yes, an electrical engineer may have a go at a repair - the rest of us mere mortals will simply toss the camera)

I accidentally bumped a piece and now it's jammed somewhere inside.

First rule of any repair: don't make the problem worse in the course of your repair. ;-)


With older gear, the cost of repair is generally much, much higher than replacement value. As of this answer, pristine condition FF-3AF's on eBay are going for ~$20 to $30. Having a repairman even look at the camera for an hour will probably cost more than that.

Your best bet with any old autofocus compact is to use it until it dies and then replace it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.