0

I am facing a strange issue with my Nikon D5300.

Today morning when I switched on my camera, 1. it's screen went black (no display) 2. i could hear a motor sound as if its trying to focus and upon restart it focuses automatically without me even pressing the shutter button. 3. after that i am not able to move the focus points nor am I hearing auto focus beep sound on half-shutter press (note my camera was set to AF-S mode)

The focus done by camera as mentioned in step 2 is the only focus it does. However, I am able to take photo by full pressing the shutter button but nothing displays on the LCD. I confirmed this by reading my memory card in computer.

Troubleshoot I performed a. I tried to change my battery that was fully charged but same problem persisted. b. Changed the lens too but again no help. Same issue persisted here also. (Lens was in AF mode)

However, I am able to move the focus point if I put my both the lens to M focus mode.

There seems to be multiple problems here. Has anyone faced such issue? Please help !

1

The basic problem is your camera is broken.

You have two basic solutions:

  • Send it in for an assessment and repair estimate. If the repair estimate isn't more than the camera is worth consider getting it repaired.
  • Replace the camera. You could try to find another used D5300 or decide to upgrade to a newer or better model.
  • Thanks Michael. The issue got fixed. Had given Nikon Service centre. It seems there was dust near the shutter button due to which the switch was short. Hence the issue. Basic checking solved the issue. – Nayan Soni Jul 18 '17 at 1:40
  • Yes, dirt and debris in the power switch around the shutter button is a known issue with many Nikon entry level cameras. We've had a few questions here that have addressed other symptoms of the same problem, particularly the "green light of death" issue. – Michael C Jul 18 '17 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.