1

I have a Nikon D7200. I've been having this issue since I bought it (close to a year ago) where after taking X pictures (X being anywhere from 10 to 200), I get a "Card Error" and it refuses to take more photos.

If I take the card out and insert it into another device (say, a laptop, or another camera), and then put it back into the D7200, everything works fine. I don’t have to reformat it or do anything other than mount/unmount. I’ve also tried things like just turning the camera off for a while/removing the battery and trying again, this does NOT help - I need to insert the card into some other device.

The D7200 has two card slots - this happens in both of them, so it isn’t the slot. I’ve tried it with 3 different SD cards of different brands, so it isn’t the card. I also updated the firmware, no luck.

I’ve googled and haven’t found anyone else with this same problem. Does anybody have any ideas?

  • 2
    What happens if the camera gives you a "Card Error" and you remove the card in the camera and use a different card? – Michael C Jul 15 '17 at 20:00
  • The new card works, but the old one doesn't (until I 'reset' it by putting it in another device). – Jarred Barber Jul 15 '17 at 21:44
  • Hey I've same problem did you fixed? – Javier Sep 2 '17 at 13:12
  • 1
    Can you please mention the error or any photo of that? So that we can suggest you solutions 🤗 – Dr geek Sep 3 '17 at 2:48

protected by mattdm Oct 9 at 15:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.