1

I have a Nikon D5200, I am not able to delete photos on the SD card when it's connected to the computer. It shows, "The memory card is write protected."

I had searched on the net and found an article explaining how to remove write protection. I removed the write protection and then used the SD card with the camera. I tried connecting again to the system and it shows the same write protection issue.

Can anyone help me in this?

4

Check the side of the SD card. There's a write protect switch that may have been moved to the 'lock' position.

  • To be more specific, it is usually silver/gray in color and very tiny. Test it by sticking it back into your SD reader and creating a .txt file in a directory to make sure you have the ability to write. – schnipdip Jul 10 '17 at 17:31
  • BobT & schnipdip thank you for your responds, I had checked with the button, it's not locked. Even its in unlocked mode can't able to create a .txt file or remove any photo from it – Gokul P P Jul 11 '17 at 5:30
1

Solution 1:

  1. Start > Run > cmd
  2. type "diskpart" -> runs diskpart.exe from system folder
  3. type "list volume" -> now you see all your connected drives, see which one is the drive
  4. type "select volume #" -> # being the letter of your drive
  5. type "attributes disk clear readonly" -> removing the protection
  6. Then open your SD, you can now edit, delete, move files.

Solution 2:

  1. Plunge this drive or memory card to a computer. (Of course, you should use a card Reader to connect your memory card.)
  2. Click “Start” on the taskbar to open “Run” and type in “regedit”.
  3. Hit “HKEY_LOCAL_MACHINE” to expand “System”.
  4. Find “Current Control Set” in “System” list to click “Control”.
  5. Check whether there is a key named “Storage Device Policies” to change the digit in the “DWORD value” box into "0" and press “OK”. But, if you cannot find the key named “Storage Device Policies”, you are supposed to create a one: right click “Control” to create a new key and name it as “Storage Device Policies”=> right click this new key to open “DWORD Value” and name it as “write protect”=> Double click it to change number.

Reference: TomsHardware

  • previously I had tried the first solution need to try the second one – Gokul P P Jul 11 '17 at 17:05
1

Have the same issue with my Panasonic lumix gx800. From a bit of googling, I understand this is normal behavior for cameras, presumably to avoid any loss of photos by human mistakes, data corruption, ransomware etc. Makes sense, I think, but would be nice to have an option in settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.