1

... and i was able to fix that with a small screwdriver putting it back into place with help of a youtube video. The problem i have now is that when i take a picture through the viewfinder of my camera, it looks different then when i take it via live view. I will attach two pictures that should look exactly the same and you will see what i mean.

This is not about exposure or anything, the problem is that i'm "aiming" at the same point and this is the difference. The first picture is taken through the viewfinder.

Did anyone have this problem already and maybe knows how this could be caused and how i can fix it?

viewfinder

liveview

  • Are you sure the same difference between images taken in LV and images taken via the viewfinder wasn't there before and you just didn't notice it? – Michael C Jul 9 '17 at 23:04
  • You'll need more reputation before you can upload images directly. The usual workaround is to upload them somewhere else, such as Flickr or imgur and post links in the question. One of the users with enough rep will usually then convert them to inline images. – Michael C Jul 9 '17 at 23:07
  • I think it worked, i just had to convert them to jpg before it was able to upload them. – destination_skyline Jul 9 '17 at 23:12
  • This is not about exposure or anything, the problem is that im "aiming" at the same point and this is the difference. The first picture is taken through the viewfinder. – destination_skyline Jul 9 '17 at 23:12
1

So you're close but no cigar on getting the mirror back in position. It's not seating all the way back down to where it should in the "down" position, so when you take a shot through the viewfinder, that extra bit of an angle is tricking you into thinking things are a bit lower or higher than they actually should be to hit the sensor when the mirror rises and the shutter opens.

It's definitely a mechanical rather than electron issue. Have another good look at the mirror and work out if it's either not seating far enough, or if something's bent and it's retracting too far on the spring.

I'm playing with a D5300 and there's a fair amount of tension on the mirror keeping it in place.. are you experiencing that too? Be gentle.. use a toothpick.

K

  • thanks a lot for your comment! when i manually push the mirror up to the "lock" position there is some tension – destination_skyline Jul 9 '17 at 23:25
  • Will have to check again with more light in the morning, its hard to see much with artificial light at night – destination_skyline Jul 9 '17 at 23:25
-1

I have been in the Photo Equipment Service and Repair industry for well over 30 years.

I state then with some degree of certainty that your mirror has likely popped out of it's hinge. Your attempts to fix it by forcing it may well have bent some of the parts that control the mirror movement. I strongly suggest taking it to an experienced repair center or to a Nikon authorized service center to have it properly repaired. You can expect to have to pay for this service plus the additional cost of any damage trying to force it may have caused.

Following a no doubt well meaning YouTube video is almost in the same category of attempting open heart surgery by watching it on YouTube.

I wish you the best......

  • 2
    FYI: This comes off as totally condescending to the poster. The "you probably made it worse - take it to someone who knows what they are doing" in general rubs people the wrong way. Sounds like you're the expert here - so maybe something a little more constructive? – KeiferJ Jul 12 '17 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.