1

I installed Magic Lantern on my camera and had shot videos and photos with it. Everything was working normal until one day I turned it on and it was broken.

Now it doesn't take pictures even though the shutter is releasing just fine. No images are saved. Instead it shows a black screen with horizontal and vertical lines. The liveview is not working either. It's all black and gets stuck.

I removed Magic Lantern. I installed the 2.1.2 firmware twice. I formatted the SD CARD. I removed the battery several times. I even removed the small round battery and reinstalled it. I removed the lens. I looked inside the mirror and behind it, but nothing looks crashed or broken.

  • How did you remove Magic Lantern? – inkista Jul 3 '17 at 3:27
  • 1
    Have you tried a different SD card as well? – laurencemadill Jul 3 '17 at 8:42
4

It sounds like some kind of issue with the digic chip itself. Since things were working after the install of ML for a while, I doubt ML was the source of the problem.

I don't know if it is the same for the 5D Mark ii, but I know that on my 5D Mark iii, the shutter actuation and image capture is distinct from the menu system itself as I had an issue with moisture causing my menu systems to not work for a while but I was still able to capture images.

It sounds like you are having the opposite problem, the shutter actuates fine and the circuitry responsible for driving the menu system is fine, but the actual hardware responsible for driving the sensor and image capture appears to be malfunctioning.

I doubt there is much you can do other than sending it in for repair as you've already done all the user serviceable stuff I can think of. Most likely either the sensor itself or the digic chip that processes the output of the sensor will need to be replaced.

  • In theory, removing the clock battery purges all settings, but if you haven't explicitly tried a "Clear All Camera Settings", you should try that before giving up. – dgatwood Jul 4 '17 at 3:13
  • Also, you should try reinstalling Magic Lantern and see if the problem goes away. If it does, then it is probably some setting that isn't getting reset correctly. – dgatwood Jul 4 '17 at 3:14
  • 1
    Ah. Never mind. I thought that the failure occurred after removing ML. Yeah, I agree with you that odds are good that the main board is fried, though it could also be that one of the voltage outputs from the DC-DC power board has gone dead, or that the ribbon cable that provides power to the main board is partially unplugged. – dgatwood Jul 4 '17 at 3:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.