0
\$\begingroup\$

I bought Capture NX2 years ago. I love it for many reasons. Unfortunately, I cannot install it on OSX 10.12 (Sierra). Strangely, I had Capture NX2 on another mac, and it still works after upgrading to Sierra. The new install is the issue. I cannot install it on my new Mac.

It seems to me that it does work on Sierra, but is prevented from installing for some reason. I tried the newer version, Capture NXD, but it truly is a downgrade, for many reasons.

Any idea how to manually transfer the app from my old computer to the new one. I have tried several things, but no luck.

Any ideas would be greatly appreciated.

\$\endgroup\$
4
  • 1
    \$\begingroup\$ You may get lucky here, but you're more likely to get help from the apple or superuser sites. \$\endgroup\$
    – MikeW
    Jun 29, 2017 at 5:05
  • \$\begingroup\$ What error are you getting? I tried installing to El Cap using Pacifist & though I got it to install it wouldn't run. The installer itself has a versioning issue - I suspect it's one of those where the installer thinks 10.12 is 'lower than' 10.5, but I haven't been able to figure out where that comparison is made. \$\endgroup\$
    – Tetsujin
    Jun 29, 2017 at 8:58
  • 4
    \$\begingroup\$ I'm voting to close this question as off-topic because it's about application/OS compatibility and not photography. Might be a better fit at apple.SE or superuser.SE. \$\endgroup\$
    – inkista
    Jun 29, 2017 at 18:50
  • 1
    \$\begingroup\$ No problem, I posted it in Ask Different. \$\endgroup\$
    – Fed
    Jun 29, 2017 at 19:08

2 Answers 2

0
\$\begingroup\$

I had the same issue when I upgraded from Mavericks straight to Sierra. Capture NX2 broke. However, I had earlier installed Capture NX2 on my wife's computer running Yosemite. In desperation I copy/pasted the program from her computer to mine and it is now working in Sierra. This was more by luck than design so I cannot guarantee the same results.

Process:

  1. Disable SIP (system integrity protection). Please check online how to do this. It can be re-enabled later. This step may or may not be necessary but it was what I followed.

  2. Please uninstall everything Nikon related from Sierra first. Make sure you clean up any Nikon associated files from /Library/Application Support and /Libraries/Preferences in Sierra. This will have to be done manually.

  3. Then copy/paste from a Yosemite computer running Capture NX2 2.4.7. I copied the following folders and files:

    1. The NIKON software folder from Applications to Applications on the new computer.
    2. Copy the Nikon folder from /Library/Applications Support (it contains a Nikon subfolder which in turn contains a further six subfolders) to /Library/Application Support on the new computer. Subfolders in Nikon folder listed below:

      1. Capture NX 2
      2. Common
      3. OptionalPictureControl
      4. Picture Control Utility
      5. Profiles
      6. Uninstaller
    3. Copy all Nikon-related files from /Library/Preferences to (Macintosh HD)/Library/Preferences on the new computer. Files listed below.
      1. Capture NX 2.plist
      2. jp.co.nikon.MCA.plist
      3. jp.co.nikon.MCA2.plist
      4. jp.co.nikon.Nikon Message Center 2.plist
      5. jp.co.nikon.UninstallCenter (this one is a folder)

Thats it. I was surprised it worked as it was last ditch attempt. I had tried all the other methods I could find on the internet without without success. I hope this works for you but like I said earlier this was more by luck than intent.

I had read online that users who gradually updated their OS incrementally though the various iterations of OS X retained Capture NX2 functionality. Skipping iterations especially after Yosemite was the problem. It is crucial to have this working on Yosemite before upgrading to later versions of OS X.

\$\endgroup\$
1
  • \$\begingroup\$ I tried it without disabling SIP, and it worked great! Thank you so very much. Too bad I didn't check here first. \$\endgroup\$
    – Fed
    Jun 30, 2017 at 1:27
0
\$\begingroup\$

I had the same problem (?) a few weeks ago where I couldn't install any of the Nikon apps. I'm on Sierra 10.12.5.

The solution, which I found somewhere on the internet but can't remember where, was to run the installer binary directly instead of launching the "Welcome" app on the disk image in the normal way.

  1. In the Finder, right-click the Welcome app and select Show Package Contents.
  2. In the resulting Finder window, navigate to Contents -> MacOS.
  3. Double-click the file named "Welcome" in this folder. A Terminal window will open.
  4. Once the Terminal window is open, click on it if it's not the frontmost window, then press Enter.

The real installer app will open and you can proceed with installation.

\$\endgroup\$

Not the answer you're looking for? Browse other questions tagged or ask your own question.