0

I dropped my Canon 450D and am now beset by "Error 99", but I believe there's a mechanical reason for it. The camera body makes a screeching sound whenever I:

- Load the battery
- Move the On/Off switch to On
- Remove or attach a lens

Furthermore, I can see that the mirror vibrates as though the camera is trying to do something to it, which suggests to me that the mirror/shutter motor is working, but something has come misaligned; and presumably the reason that the mirror/shutter motor is being activated is as part of the sensor cleaning mechanism.

These two videos show the issue (sound-enabled):

https://streamable.com/qqls4

https://streamable.com/kjtt4

The engineer in me would like to fix the camera, but before I try track down a PH00 screwdriver, I'm interested to know if anyone has any ideas of what exactly has gone wrong.

Thanks in advance.

  • The mirror does not move during the sensor cleaning routine, The shutter does not cycle with the 'auto clean' on startup or shutdown, but does cycle when doing a manual 'clean now' via the camera's menu. Even then, though, the mirror stays in place in front of the shutter. The only time the mirror moves for a cleaning routine is when you select the 'clean manually' option that leaves the shutter open until the camera is powered down. – Michael C Jun 11 '17 at 10:11
1

The mirror is obviously stuck in the up position when it should be down at any power off. The camera is probably trying to clear the mirror by doing a cycle of the mirror motor.

Before you start trying to disassemble it you might try to gently see if you can get the mirror to release from the up position. It might be as simple as a misalignment issue. Just don't force anything at this point if the mirror looks like it is still aligned squarely at the top of the mirror box.

The shutter curtains also appear to be at the end of exposure position (the first curtain is open and stored at the bottom of the sensor and the second curtain is closed) and need to be reset to the default position of first curtain closed and second curtain stored at the top of the sensor.

I'm pretty sure the 450D does not have a mirror driven by a motor in both directions, but rather uses a spring driven return when released by the mechanism that retains it in the up position. This spring might have become dislodged from its contact points. (Some of Canon's newer upper tier bodies, mostly those with frame rates of 8-10 fps or more do have a mirror that is motor driven in both directions.)

It may wind up being that the motor that drives the shutter has lost its connection with the shutter curtains and the camera won't release the mirror until the shutter curtains have been reset. I'm not sure which must be confirmed first before the camera will proceed with the other: shutter curtain reset or mirror down. It all happens so fast I can't tell from any of my Canon cameras.

One thing you might try is to see if you can get it in Live View mode and see if the second shutter curtain opens. If so and you can take a picture (without a lens you'll need to use M exposure mode), try to watch the shutter curtains to see if they cycle when you press the shutter button. It will be easier if you use a shutter time of several seconds to separate the beginning and end of the sequence. The first curtain should close from the bottom and then reopen to begin the exposure, then the second curtain should close from the top to end the exposure and then reopen back up into the top.

  • Thanks Michael for your indepth answer, it's much appreciated. Actually, the mirror in the "up" position is my fault. Originally it was sitting "down", but I moved it "up" to see if I got a different screeching sound "up" compared to "down". Unfortunately I was unable to bring it back down to "down". It quite happily moves back to "down" but refuses to stay there. I have removed the front of the camera and can now see a black gear and some white ones. I've conferred with a mechanical colleague of mine and he thinks the screech is from gear teeth, so I'm going to continue disassembly. – Nathan Jun 12 '17 at 6:40
  • @Nathan Are you able to get it into Live View mode? (WIth the mirror in the proper up position?) Okay, just saw you edit to previous comment. You're already a bit beyond that. It sounds like the problem is the shutter motor not engaging the shutter curtains properly if the camera was doing it before the self-imposed mirror issues, If it is like most Canon bodies, you'll have to go in from the back to access all of that properly. – Michael C Jun 12 '17 at 6:44
  • 1
    Hi Michael, sorry, I'd forgotten to reply to your Live View point - no, unfortunately I wasn't able to access any screen at all before the "Error 99" appeared. I continued disassembly and I think I've fixed it. It seemed that one of the gears had come out of place, and after a little bit of fiddling, they seemed to run a little freer. I then inserted the battery and heard a satisfying thunk as the shutter moved. I think it's now in the position it should be, but I'm going to reassemble the entire thing tomorrow - I'll post in about 24 hrs once complete. Thanks again for your help. – Nathan Jun 12 '17 at 8:06
  • Well I've gone and disappointed myself. After the success of the shutter thunk, the camera has suddenly turned into a brick and makes no signs of life whatsoever. I've probed different parts of the PCBs - there are voltages, but no life. I'm going to have another play tomorrow but if no joy, I'll treat myself to a new camera. @Michael Clark, thanks very much for your help, very much appreciated. – Nathan Jun 13 '17 at 7:24
  • Check the switches on the battery and memory card doors. They can often be the culprit to a totally dead camera. The switches must be closed for the camera to power up at all. When the camera is partially disassembled and they are not protected by their recessed positions, they're fairly easy to break. – Michael C Jun 13 '17 at 8:16
0

I finally fixed it.

It turned out to be the gears on the "back left" side of the camera. I must have dropped it on this particular area, and a small part of the gear housing had cracked (see the arrow in the image below, it's the tiny black circle through which the screw goes), meaning that when gears engaged, the housing wasn't holding fast, but rather was rotating hence the whining-gears sound.

Anyway, I'm stoked to have fixed it and hope that this might help someone in the future! I bought a broken shutter mechanism off eBay (pictured) for about $12 and moved the unbroken housing (and gears) from this, onto my camera.

Thanks again to Michael Clark for the help!

culprit

  • Glad you got it fixed! Care to actually show your images? :) – FreeMan Oct 30 '17 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.