0

I cannot get the Yongnuo YN622N-TX controller to work properly with the Yongnuo YN685N flash unit in manual mode (haven't tried TTL mode yet).

Coming from a Yongnuo YN560-TX controller and Yongnuo YN560-IV flash units (which are manual-only) combination, I want to get the YN622N-TX and YN685N combination working in manual mode as well. With the manual-only Yongnuo set, when changing output power and zoom setting on the controller the flash responds accordingly and shows the altered values in its display and you hear the zoom head repositioning.

With the YN622N-TX and YN685N combination however, when in manual mode, the flash doesn't seem to respond to changes made on the controller to output power level and zoom setting. No sound from the zoom head being repositioned and no changing values on the flash unit's display. Firing the flash using the TEST button on the controller DOES work. Only then the power output value on the flash unit is changed and matches the setting on the controller. But the zoom head doesn't seem te move (no sound and no changed values).

I can't get this to work with the YN685N flash unit either in 622R.SLAVE or in 622M.SLAVE manual mode.

However, with the YN685 in 603.SLAVE mode and when using my trusty YN560-TX controller, the flash unit DOES respond to changes in output power and zoom settings (including the repositioning of the zoom head).

I visited a store that sells both units new (I bought mine used) and couldn't get any of the four possible combinations of controllers and flash units to work. It seems unlikely that both mine and the brand new ones are defective.

Am I doing something wrong?

1

OK, I think I have it working in manual mode...

The YN685N flash should be set to 622 R.SLAVE mode and then to M(anual) mode. The Zoom setting should be set (or left) to A(uto).

The YN622N-TX commander should be installed to the camera's hot shoe, switched on and the group to which the flash is assigned should be set to M(anual) mode too.

Now, when changing values for zoom and output power, the flash responds to it. But somewhat different than what I'm used to when using the YN560-TX and YN560-IV controller and flash combination...

The zoom indicator on the flash as well as its zoom head responds not immediately, but as soon as the shutter of the camera is pressed half-way. The output power indicator on the flash however does not change. Not immediately, n'or when pressing the shutter half-way.

Only when I actually take a photo the adjusted output level on the controller is reflected in the flashes display. The resulting flash is indeed brighter or dimmer according to the changed value on the controller.

Thanks to all who got involved in this discussion and shared there knowledge and tips.

  • Annoying, isn't it! I had the same situation. Kept the 560s, sold the 685 and 622 (and started buying Godox stuff). – KeiferJ Aug 22 '17 at 20:34
  • Still hanging on to my YN685N flashes and YN622N-TX radio trigger, trying to make it work exactly as I want it to. And it does, for the most part. However, I'm still very puzzled by the pre-flash(es) when actiually taking a photo in Manual mode. I think it's the 'flash modelling', but I'm not sure. Looking for ways to disable it to see whether this solves the anoying pre-flashes and the shutter delay due to the flash powering up after the pre-flash(es)... – vtpeters Sep 28 '17 at 6:55
0

Don't put your flash in slave mode when using the radio triggers.

Slave mode is used when the flash is being triggered by another flash (the master). When using radio triggers, the flash works that same as when it is attached to the camera's hotshoe.

  • The Yongnuo YN685N is a flash unit with a wireless receiver that is compatible with Yongnuo's 603 (like the YN560-TX commander) and 622 (like the YN622N-TX commander) systems. There are no triggers involved, just the controller (on the hotshoe of the camera) and the flash unit (on a stand). – vtpeters Jun 8 '17 at 21:37
  • @vtpeters The transmitter in the YN622N-TX and the built in receiver in the YN685N are considered radio triggers. – Michael C Jun 9 '17 at 0:32
  • @Robin When you put the YN685 in wireless receiver mode the word "Slave" is always displayed to the right of "622 Remote." It doesn't mean it is in "slave" mode in the optical control system 'master-->slave' sense. It's just Yongnuo's way of saying "off-camera mode." The YN685 has no optical slave mode capability, nor any optically controlled TTL ability. It can be used only via wired hot shoe connection (including an off-camera TTL cord) or via YN622 or YN560/RF605/RF603 radios. – Michael C Jun 9 '17 at 1:23
0

As you are discovering, the YN622 and YN560 systems don't always behave the same.

When you change a setting via the YN622-TX controls (or the camera's menu if you're using the Canon version of the system), you need to do a half press of the camera's shutter button to tell the YN622-TX to transmit the change to the remote flash if it has been more than a few seconds since the TX has communicated to the flash. As far as I can tell, this is a power saving feature as the 'wake' and 'set' signals are combined in one very short transmission.

With regard to 'Auto' zoom settings, when you move the zoom ring on your lens and do a shutter half-press the head on the flash moves and the connection stays active for 2-3 seconds during which time the zoom head on the flash will move with a change in the position of the lens' zoom ring. After that 2-3 seconds have elapsed another half press needs to be done to sync the flash's zoom setting to any changed position of the zoom ring on the lens.

Also, don't forget that the YN685 must be set via the flash's control panel to 'default' settings for power and zoom or the YN622-TX can not change the setting on the flash. The flash should be set to 1/1 manual power (or ±0 EC in TTL mode) and "auto" zoom (There will be an 'A" to the left of the displayed zoom head position) using the control panel on the flash in order to allow the YN622-TX to change those settings. If the flash is set to another power level (or EC setting in TTL) or a specific zoom setting (There will be an 'M' to the left of the displayed zoom head position) via the flash's control panel the YN622-TX will not override those settings.

The behavior you describe in your question would be exactly what one should expect if the the last power setting applied using the YN685N's own control panel was 1/1 but the last zoom setting applied using the YN685N's own control panel was anything other than 'Auto' (also note that pulling out the diffuser panel on the flash is manually setting the zoom to 'wide' and the zoom head will not move regardless of the setting made via the YN622N-TX. You're also locked out of changing the zoom setting on the YN685's control panel when the diffuser panel is pulled out).

I've also seen situations where specific older firmware versions of the YN685 and newer firmware versions of the YN622C-TX lead to the display on the YN685 not accurately displaying the current settings entered via the YN622C-TX. When I take the picture, though, the settings displayed on the YN622C-TX are applied. When I set the power to 1/128 via the YN622C-TX and/or the camera's menu and the flash's panel still shows 1/1 it's pretty obvious when I take a picture I am only getting 1/128 power as opposed to full power.

By the time the YN685N was released almost a year after the YN685 (the Canon version does not have a 'C' in the model name) I think Yongnuo had worked through all of those issues. As far as I know the firmware of all YN685N units can be updated using an updated YN622N-TX and the 'Yongnuo Trigger Updater' application. You plug the YN622N-TX into your computer and it transmits the new firmware to the flash. Some of the early firmware versions of the YN685 (Canon version) can not be updated by the end user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.