2

I have recently invested in a Nikon D810 and have just purchased a Sigma 70-200mm f2.8 EX APO DG MACRO HSM II lens. When shooting I have a visible frame through the view finder and all images are cropped to the frame (as though the camera/lens is DX not FX). Can anybody help/advise where I'm going wrong?

5

It's possible the lens is miscommunicating with your camera. If the camera's Auto DX crop setting (under Shooting Menu > Image area) is set to "On", and if somehow your camera is interpreting the lens as a crop lens, then it will automatically crop the center of the sensor when it takes images, and will draw the DX crop reticle you see in the viewfinder.

Try removing the lens, turning off Auto DX crop, and then attaching the lens. If this resolves the issue, then you should leave that setting off.

  • Scottbb thank you!! Yes that has worked, thank you so much :) – C Hall Jun 1 '17 at 6:45
3

I have seen that on a Nikon D800, with Nikon 24-70 FX lens.

If you select DX format, it does that DX, even with the FX lens.

Then if you put it back to Auto DX crop, it still stays on the DX crop, even with the FX lens (which I'm thinking is what you see). Power off/on has no effect on it. It would seem to be a bug.

Then if you select FX crop, then it does that FX.

Then putting it back to Auto DX crop properly does Auto DX (i.e., remains at FX with a FX lens).

This is very repeatable for me. If you specify DX crop, then you have to specify FX crop once, before you select AUTO DX again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.