0

I've started having this intermittent issue on my Nikon Df.

Occasionally (1 out of 50 shots?) I take a photo but the viewfinder goes dark and doesn't re-open.

When i press it again it re-opens. The photo still captured perefectly.

initially i thought this was a lens issue but it's happening with different lenses so likely the dslr.

does anyone know what it is exactly and best place to fix it (refurbished out of warranty)?

  • Let's go over the most obvious culprits, in case you haven't already done that: Have you checked whether you're in bulb mode? Have you checked whether mirror lockup is enabled? It would be lovely if the behaviour you're describing turns out to be a feature, rather than hardware damage. ;) – ParaDice Apr 19 '17 at 19:02
  • @ParaDice haha thanks, yah it happens only occasionally and lately i've been shooting aperture priority with ISO in 100 - 1000 range.. so no bulb :( – Sonic Soul Apr 19 '17 at 19:04
  • Different camera model but same issue and possible solutions: Nikon D90 mirror stuck – Michael C Apr 19 '17 at 20:21
  • 4
    Possible duplicate of Nikon D90 mirror stuck – Michael C Apr 19 '17 at 20:22
1

So for some clarity, when you look through the viewfinder, you're looking into the prism bounced of a mirror inside of it, then down to the big mirror that you see when you take the lens off.

When you take a photo, that mirror bumps up out of the way, and the shutter fires, exposing light on the sensor, then the mirror returns "home".

So.. it's a "mirror returning home" issue that you are experiencing.

Are you using after market batteries or does this only happen when you use a specific battery (if you have several?) or when battery is low on charge? I experienced exactly the same issue on a D700 with one battery when it hit about 30% charge. I see no logical reason for this to be the culprit, but I'm convinced after much testing that it was.

  • hmmm i do have 2 batteries and one may be after market. it actually has not happened in a while, possibly because i was working with the other battery?! – Sonic Soul Jul 19 '17 at 22:02
  • Could be. Worth keeping an eye on.. That's my bet anyway. – KeiferJ Jul 20 '17 at 3:52
  • i like this theory. will report back – Sonic Soul Jul 20 '17 at 13:51
  • 1
    im glad i didn't give my camera up for service, since they'd probably f it up more :) – Sonic Soul Jul 20 '17 at 13:51
0

Based on the information you have provided so far, the shutter seems to be okay: photos are being taken without a problem, even if the viewfinder "goes dark".

The problem appears to be with the mirror, which is responsible for redirecting the light from the lens into the viewfinder, thus giving you a picture there. Normally, it swings up whenever you press the shutter release to allow light to fall onto the sensor. It seems like it is "hanging" occasionally and does not swing back into its normal position, thus the "missing" image in the viewfinder.

You may want to take the lens off your camera and take a few shots until the viewfinder problem occurs again, then look into the camera; if the sensor is visible, then the mirror problem is confirmed. Maybe you can also see what's keeping the mirror from returning to its original position.

The rest is up to you: if you feel comfortable around taking cameras apart, feel free to grab a screwdriver and get to work! ;) Otherwise, you may want to seek a certified Nikon repair shop or a free one. Either way: Best of luck with getting it back to work!

0

I have the same problem. It is a mechanical problem of the shutter release. The cause is that the shutter button does not return to the top. It sticks in middle position, like it has some dirt inside. Please look carefully at your shutter release buton when the problem occurs.

When it happens to me, I try to blow it with air, but no result.

Maybe it should go for service to Nikon shop.

  • interestingly my problem just went away and i haven't seen it since last early summer :/ – Sonic Soul Jan 21 '18 at 19:34
-2

This is the mechanical problem. Shutter operating motor's gear may be cracked. It should go for service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.