4

I can't figure out how to turn on the Bluetooth on my Nikon D5600. I have updated the firmware to the latest 1.01 and still the same problem.

Bluetooth is dimmed out on the camera and will not turn on. I get an error message saying, "This option is not available at current settings or in the camera's current state".

I have tried everything I can think of and no go. I can't find help for this problem anywhere on the internet and still no reply from Nikon.

How do I turn on my camera's Bluetooth?

2

Bluetooth isn't setup directly from the menu on the d5600 and other SnapBridge enabled cameras. Instead, you have to use the WiFi or NFC linkage from the SnapBridge app to get your phone or tablet to pair with your camera on Bluetooth.

You can view or download the pairing guides and manuals (pdf) for the d5600 at this location: Nikon D5600 Download Center

I've only gone through this process with an iOS device and a D500, but here are the basics and the guides at the aforementioned link have the same steps:

  1. Make sure your camera is not in Airplane mode.
  2. Setup WiFi on the camera first, and note that the camera is hosting the WiFi network. You won't actually be able to connect the camera to an existing AP. You can set a password for this ad-hoc WiFi network on the camera.
  3. Connect to the WiFi network from your device, using the name of the network and password for it that is configured on the camera.
  4. On your camera, locate the "Connect to Smart Device" option in settings and activate it.
  5. Launch SnapBridge on your device. If the WiFi connection dropped (this happens often on iOS), it may prompt you to activate it again. Simply go back to your WiFi settings or use the prompt button in the iOS Snapbridge app and reconnect to the AP/network hosted by the Camera when directed to the phone/tablet settings. Return back to the Snapbridge app after the wifi network is on the camera's AP.
  6. If everything has gone well, it should detect the camera and you'll be prompted to verify the bluetooth code on both devices, and from here the pairing goes the same as any other bluetooth device, except that it is within Snapbridge.

Note that if your camera battery is not at 85% or better charge, you may have trouble connecting to the WiFi AP/network hosted by the camera. This is mentioned in the docs but worth repeating because out-of-the-box or after even moderate camera use, the camera's battery will not be fully charged and you will have to wait for a full charge to setup Bluetooth/Snapbridge. I carry an extra battery with me in the field if I anticipate needing to use SnapBridge.

Last, I had one more quirk that I couldn't duplicate, but just in case: If you setup a WiFi access password on the camera containing a space or an underscore, you might not be able to connect to it from your phone or tablet. I wasn't able to duplicate this issue again after the 1.06 patch for the D500, but if you've done the same, it may be worth trying a new password for WiFi that only has alphanumeric characters.

2

I just received a D5600. I have a Motorola Droid (XT1080) running Android OS. It has BT, WiFI and NFC. I installed the SnapIt was somewhat challenging getting the phone to pair with the camera via Bluetooth. Even more of a challenge having it connect via WiFi. Here are the steps that eventially worked (although the WiFi is still not reliable). Sorry about the lengthy wording, but I think it helps to know details along the way, as the camera is not particularly obvious about what's going on.

First, when the camera is initially turned on, under the SETUP MENU (wrench icon), scroll down to page showing WiFi, with Bluetooth just beneath it. The Bluetooth may be dimmed and selecting it gives the message you describe. Above it, you can select the WiFi to see the sub-menu. I suspect you will see all 3 items (Network settings, Current settings and Reset connection settings) are bright and can be selected. At one point I changed the SSID and password, even turned off the Authentication ("open"). It did not have an effect on the eventual result, and they returned to their factory version later on. So I would leave those alone. But you should note the SSID (e.g. D5600_2035566) and the password (e.g. NIKOND5600) under "Current settings" for later use.

OK, so the 1st thing to do is make sure the Bluetooth is set to "Visible to all nearby devices" and the NFC is set to "Allow date exchange when phone touches another device". I went to my phone's Settings menu (cog symbol) to get to these. For the NFC, I had to select "More ..." to get to the relevant sub-menu with the actual NFC settings. This may be specific to my phone and Android version. I also turned on "NFC Security Reminders" and "Android Beam" so that it is ready to transmit app content via NFC.

Second thing was starting the SnapBridge app on the phone. First time you need to accept terms of use, and then a screen comes up telling you to tap the phone's NFC antenna area onto the D5600s antenna. Go to the D5600. On the same SETUP menu area, two lines above Wi-Fi, will be "Connect to smart device". Select that and you see a screen with "Use SnapBridge ... blah blah blah" and "To skip this screen ... blah blah blah. Press the OK/Set and you see a screen showing a phone tapping to a camera. Note that the D5600 antenna location is on the side of the camera, just above the memory card slot and in front of the HDMI port (there is a symbol for the NFC thing there). My phone has the NFC antenna on its backside, just below the camera/flash/speaker openings. When I put that location directly touching the D5600 NFC symbol, they beep and the camera name (same as the SSID) shows up on the SnapBridge phone app screen. You choose that on the app screen. Then the camera shows a code number and asks to confirm that the code is the same as one showing on the phone app. Confirm and the Bluetooth gets paired. If you are successful, you will see that the SETUP MENU for Bluetooth shows ON. Also, if you select Wi-Fi, only the Current settings is bright (the others are dimmed and no longer work).

I suggest closing and re-starting the SnapBridge app on the phone at this point. It should show a screen with a phone symbol on left and camera on right with a circle connecting them (and the BT symbol in the middle). You now have BT connection and can view or download images no larger than 2Mb (2nd icon from left near top -- with mountains in a frame). But the Remote photography and the Download selected pictures (full size) need the WiFi. Those two features are under the next SnapBridge icon (camera symbol).

For the phone WiFi, turn it on and go to the usual setup menu for choosing the appropriate network (access point). On my phone there is a plus sign "+" at the bottom that is used for adding a network that does not automatically appear. The D5600 apparently does not broadcast its SSID. You enter the SSID (from above), select WPA-WPA2-PSK/AES security method and enter the password, then done/save. Now, go back to your phone and open SnapBridge again. It should go right to the page showing that the camera and phone are paired via BT and ready. Select the little camera icon near the top and from the new menu select either Remote photography or Download selected pictures. It will show a progress bar for "Establishing a connection to the camera". Sometimes this is reasonbly quick (a few seconds). Other times a minute or two. Other times it fails with a failure message. For me, I always got the failure message until I re-booted the phone in SAFE MODE. Apparently this clears some of the Android caches that prevent the special WiFi connection method Nikon uses. I then re-started in normal mode and that got the two things to connect by WiFi. Whew!!

Some other things that may help. First, I set my phone to not automatically connect to any network that it normally sees (i.e. my home internet WiFi router). Second, my phone can be put into SAFE MODE by pressing and holding the power button (usual step to turn phone off) and then pressing and holding the "Power Off" confirmation on the screen. A subsequent re-start will put you back in Normal Mode (there may also be a little icon in the status area that you can select to return to normal).

In sum, it seems that the D5600 needs to connect via NFC before it turns on the BT. Then, the SnapBridge has to be running and connected via BT to get the WiFi to turn on and connect. When the WiFi is on, I can actually see it on my laptop WiFi. There are also little icons on the camera's normal screen for taking photos (the one showing the shutter speed, f/# and ISO in circles). The icons appear at the top, to the left of the "Fn" icon. One is the BT icon, the other is the WiFi antenna symbol.


1

I had similar issues and I had to uninstall the SnapBridge App from my phone and then reinstall the app. Then followed the connection directions. Only way I got mine to work.

0

All worked well for 2 months. Somehow Bluetooth stopped working and only grey displayed. Reset camera twice. No joy. Struggled with the D3400 Bluetooth syncs to the snap bridge. iPhone showed camera in blue tooth but would not connect. Said make sure camera is in range or phone on. After jerking around for a couple of hours finally decided to forget the camera from the Bluetooth devices and once camera removed from paired devices.

Strongly anyone with D3400 Bluetooth issue to “Forget” camera from Bluetooth devices and reload.

0

The problem can be fixed by following the steps, Initially I too had the problem, but later I fixed it by my own.

  1. In your Android device, go to bluetooth and enable it. Then check for all the paired devices. Identify the name with which Android device connect with camera and unpair it.

  2. In your Android device go to Wifi and enable it. Then go to manage saved networks and identify the name with which Android device connect with camera and select "forget".

  3. Go to settings of your Android device and click on installed device in the list. Sind SnapBridge and then click on Clear Default Settings.

  4. Switch on Nikon D5600 > Press menu button > Settings > Connect To Smart Device.

  5. In your Android device, open the SnapBridge app.

  6. Then pair the device with the access code given by the Nikon camera.

That's all it should work.

  • Hi Touhid and welcome to Photo.SE! I am not entirely sure how your answer contributes to this question. The other two up-voted answers already seem to cover the points you mention. – Saaru Lindestøkke Feb 6 '18 at 11:35
0

Nikon D500 - I had same problem - Bluetooth greyed out on camera. I had Snapbridge working properly and then activated NFC on phone Samsung Galaxy S9+. That stuffed everything. Couldn't get it to work again. Eventual solution was it uninstall Snapbridge and reinstall - now works perfectly.

-2

Down load SnapBridge on your phone. Go to Conect to device on the camera and follow the steps.

  • 3
    Isn't this what the existing answer already covers in detail? – MikeW May 19 '17 at 0:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.