0

I've been searching for several days now, and while this is a very common problem in Google Land, none of the fixes presented are not working. So far, I have:

  1. Installed EOS Utilities
  2. Updated to current version (v2) from Canon site
  3. Upgraded firmware
  4. Uploaded and installed
  5. Tried several different USB cables
  6. Tried my other camera, a 6D, on the laptop - it wasn't recognized either.
  7. Tried both cameras on my desktop computer - both were recognized
  8. Tried all three USB ports. Finally the third one recognized it, and said it was installing the software. "Canon Camera" now appears under "Other Devices" with a yellow triangle.
  9. Disabled, then enabled it, then scan for hardware changes.

Not sure if it is relevant, but when I launch EOS Utilities, all I get is a screen that says "Connect and EOS Camera" with two options: Pairing over Wi-Fi/lan and Close.

I'm out of ideas. Can anyone here help?

  • Do you have access to the EOS Utilities 3? – thebtm Apr 12 '17 at 19:17
  • inkista: I want to connect my 60D. As part of the long trail of troubleshooting, I tired to connect my other camera, which is a 6D. Using EOS Utility 2 thebtm: I don't believe v3 works with a 60D. – Dale Apr 12 '17 at 20:33
  • @Dale If you install EOS Utility 3.6.0 it includes EOS Utility 2.14 which will be started if you connect an EOS camera not supported by EOS Utility 3. Since you're only having the issue with the laptop the newer version of EOS Utility might solve your problem. – Michael C Apr 12 '17 at 23:06
  • What OS are you running on your laptop? On your desktop? – Michael C Apr 12 '17 at 23:06
  • @Michael Clark I am running Windows 10 on both. I installed 3.6.0 last night, and still having the same issues. (was surprised to find v2.14 was inculded) EOS still has three of four options greyed out. Monitor Folder is the only working choice. In Device manager, Canon Digital Camera appears when plugged into two of the three USB ports, but with the yellow triangle. Also,Unknown USB Device (Link in Compliance Mode) appears under USB controllers, and it also has the yellow triangle. – Dale Apr 13 '17 at 13:07
0

After trying "Driver Easy" which claims to udate all missing drivers (it didn't), I finally found the solution for me, which was go to the microsoft site and update to Windows 10 Creator, which isn't called by the usual Windows Update.

After I installed it (takes about 2 hours), the camera is recognized, and EOS Utility works.

Here's the link: https://www.microsoft.com/en-us/software-download/windows10

Hope this helps someone down the road.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.