2

I'm having troubles loading a new film in my Olympus OM 10 camera.

I'm following the notice so I'm not sure what I'm doing wrong. I think I'm loading it right, but the problem seems to come from the film advance lever (the lever you pull toward yourself to take a new picture). It's locked and I cannot pull it. It's on S on the indicator. Is that normal?

enter image description here

  • Have you tried releasing the shutter? – Michael C Mar 20 '17 at 12:02
  • That means like taking a picture, right? Yes, I've tried it, it is not doing anything... – francoiskroll Mar 20 '17 at 12:13
  • Is this the first roll of film you have tried to load in the camera? Or has it worked as expected with previous rolls? – Michael C Mar 20 '17 at 12:14
  • It worked as expected with one previous roll (just after I bought the camera). A friend did it to show me how you were supposed to do it, but it looked rather straightforward, I don't think he had this issue... – francoiskroll Mar 20 '17 at 12:22
  • This is the notice pdf I'm following, if it can be of any help (loading a new film is page 12/13) vieilalbum.com/documents_fichiers/Manuel%20Olympus%20OM-10.pdf – francoiskroll Mar 20 '17 at 12:22
2

Pages 11-14 of the Olympus OM10 Instructions outlines how to load film into the camera. It sounds like the leader is not inserted into the takeup spool enough to move the film when you cocked the lever the first time (similar to the "No" illustration at the bottom of page 13. If the film doesn't engage the sprockets properly the shutter will not be reset and the film counter will not advance.

Also keep in mind that the battery must be installed in the camera for the shutter to function. Without releasing the shutter you won't be able to advance the film (this is a safety feature to prevent you from winding the film too far after each shot).

page 11
page 12
page 13
page 14

  • Awesome, I think I got it thanks to your answer. The problem seemed to be caused by the batteries, they are empty (or almost). I took them out and put them back, looks like they had enough charge left to release the shutter. I was then able to pull the lever and roll the film. Thanks so much! Just out of curiosity, do you know exactly what job the batteries do? I thought they were only there for the shutter speed indicator, not for actually closing/opening the shutter. – francoiskroll Mar 20 '17 at 12:47
  • The shutter on the OM10 is electronically controlled. Batteries are necessary to take a picture. Please see pages 22 and 45-47 of the Olympus OM10 Instructions for more. – Michael C Mar 20 '17 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.