3

I have an external USB drive plugged in, but Picasa is not displaying that drive in "Folder Manager", and as such I'm unable to scan and view the photos on that drive.

Is there anything I can do to force Picasa to see my drive?

  • This isn't related to photography. This is off topic – Janardan S Mar 19 '17 at 10:16
  • @JanardanS I figured that it's related to photography software and workflow, and I see plenty of other Picasa questions on this site. – Simon East Mar 19 '17 at 10:28
  • 1
    @JanardanS I disagree. This is a question about a problem using a specific photographic tool. As the answer shows, the problem is not an underlying, generic, OS problem; it's specific to the tool. Certainly seems on-topic to me. – scottbb Mar 19 '17 at 12:26
4

There are certain types of drives that Picasa refuses to list in its "Folder Manager" – generally these are drives formatted with the exFAT file-system, commonly used on USB sticks.

There are two possible workarounds to handle the issue:

1. Manually edit watchedfolders.txt

If you locate and access:

C:\Users\YOUR-NAME\AppData\Local\Google\Picasa2Albums\watchedfolders.txt

You'll notice it looks like this:

D:\Photos\
D:\My Documents\
C:\Users\Simon\Desktop\
D:\Videos\

You can manually enter the paths to the folders that you want automatically scanned within Picasa.

Unfortunately if you later remove a folder from this file, it may not remove it from Picasa - it may only stop Picasa from repeatedly scanning it. For more control, you might like to use option #2.

2. Map the external drive to a local folder

The workaround for this is to map the external drive to a folder on another valid drive, such as one using the NTFS file-system. To do this:

  1. Right-click the Windows Start button
  2. Click Disk Management
  3. Find your external drive in the list
  4. Right-click and choose "Change Drive Letter and Paths..."
  5. Click "Add"
  6. Create a new empty folder on another valid drive (one that is displaying in Picasa correctly), and choose that as your mapped location
  7. In Picasa, choose Tools > Folder Manager and now add the new folder that you created. It should now contain all the files from your external drive.

Just be aware that if you later launch Picasa and your external drive is not plugged in, Picasa may think that the files have been removed and begin to wipe all memory of those photos (including thumbnails and other saved data). This is only the case when Picasa can no longer find the relevant folder, NOT when Picasa simply cannot find the entire drive. For this reason, you may prefer option #1.

Final note for drives mapped to B:

There is a quirk where Picasa refuses to access drives A: and B:. If you happen to have your external drive mapped there, it's best to open Disk Management and assign it a different drive letter, or follow the workarounds above which should also work.

  • 1
    I'm not sure why this was downvoted. This is a well-written answer that clearly answers the question. – scottbb Mar 19 '17 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.