A couple of days ago I received my new Nikon D5600. The phone I am trying to pair with is a Samsung Galaxy x7, just a few months old, with latest software updates.

I am consistently getting the same problem with the Bluetooth using SnapBridge. The sequence always goes the same: the devices see each other; I follow the prompts to pair; on the camera I get a message saying "your camera and smart device are connected"; on the phone I get a message that says "waiting for response from camera"; then after 10-20 seconds or if I hit OK/Next on the camera, I get a "pairing failed" message on the phone (SnapBridge app).

In the SnapBridge program there is a help icon that leads to a web page on pairing errors. Topics there are:

  • Did you press the camera OK button and tap pair at the same time?

    Yes I did.

  • Is SnapBridge currently paired with another camera?

    No its not.

  • Are you also running SnapBridge 360/170.

    No I am not.

  • Is GPS disabled?

    It is on.

  • Are you experiencing radio interference?

    That's possible so I took a ride where there should not be any such problem and tried again, and again at a different locale, and determined that radio interference is not the problem.

It then suggested restarting Bluetooth, which I did on both devices. I also threw in reboots on the camera and the phone just for safe measure.

I then decided to try to connect the Wi-Fi, which according to instructions is supposed to be drop dead simple. On the camera you go to the setup menu and turn it on. Then you go to your phone and look for the camera in your available Wi-Fi lists. It simply does not show up. I tried a few things, like trying it with the Bluetooth turned off in both the camera and the phone, and also tried it away from any possible radio interference, all of which failed. I have been messing with this for a couple of days with no luck.

Has anybody with a Nikon D5600 or similar Nikon body experienced this problem that might be able to share a remedy? Or do I have a lemon and should just consider sending this thing back to Nikon for repair or exchange?

Update: The update is out for the Nikon D5600. Did not help a thing.

  • \$\begingroup\$ I have a 5500 so can't help with the bluetooth. I do remember the WiFi being a bit fiddly the first time until you have the SSID & security set up the first time. Subsequent connections ought to be seamless. Maybe see dummies.com/photography/cameras/nikon-camera/… for a step by step & see if you missed anything -- if it helps, then I can turn this into a real answer, at least for the WiFi part. \$\endgroup\$
    – Tetsujin
    Feb 27, 2017 at 10:20
  • \$\begingroup\$ I would recommend seeing if there's a SnapBridge forum page. If so, it's highly likely you can find help on its Bluetooth implementation there. \$\endgroup\$ Feb 27, 2017 at 12:21
  • \$\begingroup\$ Have you tried manually adding the SSID when the phone doesn't autodetect it? \$\endgroup\$ Feb 28, 2017 at 7:06
  • \$\begingroup\$ @PeterTaylor Yes. \$\endgroup\$
    – Jon
    Feb 28, 2017 at 18:59
  • \$\begingroup\$ I am having the same issue. iPhone shows up in Bluetooth, then disappears. I cannot connect. Does not show up in WIFI settings either. Frustrated. \$\endgroup\$
    – Kelly
    Mar 29, 2017 at 19:21

2 Answers 2


Spent some time with Nikon tech support today. They said that I need a software update that is not out yet. I said that they had just released the IOS update so I pulled out my IPad mini, and I was able to connect for a few minutes to both the Bluetooth and the WIFI.

So there is no fix currently. But the guy at Nikon said the release date is "soon".


I had Iphone IOS 10.2 and Nikon D5600 with the original firmware 1.0. When I tried to connect them it worked for a short time and then stopped completely. After I upgraded both IOS to 10.3 and Nikon D5600 firmware to 1.01 I still was not able to connect. After trying different options I eventually was able to make it work after "forgetting" the Nikon device from the IPhone Bluetooth menu. I think somehow it still remembered it with the old firmware.


Not the answer you're looking for? Browse other questions tagged or ask your own question.