2

I got this one at a thrift store for 2 dollars, so no surprise if it's just wonky, but I'd like to see this thing work.

This camera actually seemed to work when I first got it and tried using it without any film loaded (took a while for the batteries to be recognized) and it appeared to be able to take pictures, rewind, focus and activate the UI in the viewfinder.

I was still having battery troubles the next day (corroded parts from the previous owner leaving batteries in) so I tried a few tricks I found online and was eventually able to get the camera to run more readily by placing some tin foil over the corroded part.

A few days after that, now having a roll of film to try the camera out with, I slip the roll in and turn on the camera and it starts rewinding the film into the can instantly (the rewind switch says "OFF" when it's switched on). I was eventually able to get the film back out, so I put it back in the camera and this time made sure the switch was set to the opposite direction and closed the back. It loaded fine, but wouldn't stop trying to advance until I closed the lens (one thing I forgot to note - you're supposed to push the shutter release to advance while the lens is open, but it started by itself).

What's the problem here, and can it be fixed? If it helps specify a problem, the manual says that the shutter release shouldn't be able to be used when the lens is closed, but I can still push it down all the way when I try that.

  • Hope you're one of us techie-hackers, 'cause you're gonna have to start taking things apart and finding the stuck switch (my guess as to the most likely culprit here). BTW, I'd recommend scraping all the corrosion off the actual battery contacts, as tin foil tends to come loose when you don't want it to :-) . – Carl Witthoft Feb 27 '17 at 12:25
  • Sorry fir the late reply, I'll try cleaning the contacts as best I can. What would I be looking for inside the camera that would be the problem? I trust myself to be able to find whatever it is, but I'm going to be lost without a definite starting point. – reeksplod Mar 26 '17 at 2:39
0

I also recently purchased the Ricoh FF3 AF. As soon as I put two AA batteries and started testing the camera without the film, camera seemed to work well.

Strange thing was, the flash fired even though it was not set ON. After about 5 shots, during a self-timer test, the camera started to wind furiously without stopping (even though film was not used). The winding stopped only when lens was covered, but as soon as the lens was uncovered the furious winding started again regardless of whether the wind/rewind button was set to normal shooting.

It took me several days to find out that the problem was caused by rechargeable batteries. I was told by a professional photographer never to use rechargeable batteries in such old 80's camera. After the warning, I tried standard Alkaline batteries, but the camera was still furiously rewinding. I thought I had damaged the camera. After about three days I tried again, and the camera started to work normally.

Seems to me there was some kind of electric shock, but no burning of the internal circuits. Just wanted to share my experience. Now going to test with film in the camera.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.