I'm using darktable (which I love!) for processing raw photos from a Canon EOS 6D on Ubuntu 16.04. It seems that when I open a raw image in the darkroom and go to the basecurve module which has been automatically applied, it's using a preset called "canon eos like". However, there's another option in the menu called "Canon EOS 6D" which produces better results. How can I get the "Canon EOS 6D" basecurve to be applied automatically instead?

The version of darktable I'm using is 2.0.3

These basecurve presets can be found in the Presets table of the settings you get to by clicking on the gear icon:

enter image description here

... but I can't see how to indicate that the preset with name "Canon EOS 6D" should be used in preference to "canon eos like". Perhaps the model field, which looks like an SQL LIKE pattern, doesn't actually match the model that's being extracted from the raw file? That doesn't look like it should be the case, though:

$ exiv2 pr IMG_0151.CR2 | egrep -a Camera
Camera make     : Canon
Camera model    : Canon EOS 6D
up vote 4 down vote accepted

In the current version of darktable (2.2.1) you can open settings > "core options" and select "auto-apply per camera basecurve presets". In previous versions, you can just create a preset using that curve and set it to auto-apply. The built-in presets are read-only, so you can't change the auto-apply status of those in the settings.

  • 1
    Thank you - the first suggestion worked with my version (2.0.3) too! – Mark Longair Jan 22 '17 at 23:11
  • Good to know, I couldn't remember exactly when that option was added. – junkyardsparkle Jan 23 '17 at 1:23

Try this:

  1. Open the presets menu and select "Canon EOS 6D"
  2. Open the presets menu again, and right at the bottom select "use preset as default"

If that doesn't work then the module is obviously being too clever, and you might have to try more complicated approaches involving editing the database of presets.

  • Thanks for such a quick answer - unfortunately I don't have the "use preset as default" option at the bottom of that menu, just "store new preset". I wonder if you have a more recent version of darktable than me? (I've only just updated my question to include that information - sorry - I'm using darktable 2.0.3) – Mark Longair Jan 22 '17 at 19:34
  • @MarkLongair, I have 0.9.3. Maybe they removed the option, although that would be a bit odd. – Peter Taylor Jan 22 '17 at 19:50
  • 0.9.3?! ...and I thought I was conservative about updates. :P – junkyardsparkle Jan 22 '17 at 20:46

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.